[SOLVED] Aeotec zwave controller going offline

My Aeotec zwave controller keeps going offline. I saw the problem with the 2.5 M5 snapshot, but it still happening with the 2.5 release. I’ve removed the thing and binding, cleaned the cache and re-installed the binding, but the problem remains.

Java opts

EXTRA_JAVA_OPTS="-Xms250m -Xmx350m -Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"


openhab : openhab tty dialout audio bluetooth gpio

Here’s what I see in the log:

2019-12-15 18:02:40.556 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2019-12-15 18:02:41.280 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-ui-"classic, openhab-misc-restdocs, openhab-ui-habmin"'
2019-12-15 18:02:45.213 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2019-12-15 18:02:45.339 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
2019-12-15 18:02:45.362 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2019-12-15 18:02:45.386 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2019-12-15 18:02:45.387 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

This repeats every few minutes. Any solution?

1 Like

I’m having the same problem. Mine barely finishes setting everything up before it kicks off another offline cycle. Thoughts @chris?

Looks like it was due to another failing binding: [SOLVED] OpenHAB 2.5 RC 1 Critical Issues

Check your addons.cfg file… see here:

I checked my addons.cfg and I have no entries there:

1 Like

You might need to check here as well…

On openhabian %userdata% is at /var/lib/openhab2

I was having the exact same issue and the restdocs causing the zwave binding to have issues. My story here:

1 Like

Is there a syntax error here:

 Failed installing 'openhab-ui-"classic, openhab-ui-habmin"'

The first double quote seems incorrect.

In the user data directory, I have this line as well:


Those escapes seem strange.

Those escapes do look strange. My “ui” line looks like this:


I believe that it should just be a simple list. Try cleaning up that line and see what happens.

I can try that, but this file is auto-generated at startup, so any changes will be lost and I’ll be back where I started. I did try removing classic-ui and habmin in PaperUI, but the system still generates this entry.

Exactly, that is the reason why it should not be edited manually.
The *.config files are populated with the contents of your corresponding '.cfg files or contents generated through PaperUI.
So the correct way is to clean your *.cfg files, delete the *.config files and restart openHAB.

1 Like

What is the location of the *cfg files? The auto-generated addons.cfg mirrors the contents of /etc/default/openhab. But I have no entries there. Every line is commented.

I got it working. I have to admit that even though I didn’t think it would work, I edited


Restarted and it worked. No more zwave controller going offline/online. I had to manually re-add some bindings in PaperUI, but things seems fine. I’ll give it a couple of reboots to make sure things are really working.


Glad it is working :+1:

Just a follow-up:
After several reboots, my zwave controller is still working just fine.



I’ve been using openhab2 with no issue, and now with the latest update I am getting the controller going off and online.

Could you explain what you mean by you ‘edited’ the file? What exactly did you edit?

Mine currently shows:


Thank you.

This line looks wrong. A double quoted string within single quotes. I think it refers to legacy 1.x bindings. Try removing it and see if that resolves your issue.