No Ethernet connection , no IP

Tags: #<Tag:0x00007efeccc25ea8>

Hello everyone,

have installed openhabian on my pi4 8gb.

It looks like my Ethernet cable is not recognized by the pi.
Does anyone here have a tip? I am not looking to connect via wifi.

Thanks in advance
Cheers

Have you performed any basic network troubleshooting?
In order to help you we need you to tell us what troubleshooting steps you have already tried.

1 Like

Hi, so I am using a FRITZ Box. No IP6 is active.
I tried different ethernet cables.
What else can I do?
My actual state is that I have just installed openhabian. nothing else.

I suggest to follow this guide:


Then you can tell us what you have done and there are also troubleshooting steps explained.

I followed this guide.
Setup:

Download the latest “openHABian” SD card image file (Note: the file is xz compressed)

Write the image to your SD card (e.g. with Etcher, able to directly work with xz files)

Insert the SD card into your Raspberry Pi, connect Ethernet (WiFi also supported) and power on.

Wait approximately 15-45 minutes for openHABian to do its magic.
(You can check the progress in your web-browser here.)

Enjoy!

The device will be available under its IP or via the local DNS name openhab

–> but i do not get an ip address

Try a different network port?
Try another network device on that port & cable to verify both are functioning as expected?
Try the Pi on a known functional port & cable combination?
Try a different image on the card to verify the Ethernet port on the Pi is not defective?

Exactly what version did you use? I believe the 8GB Pi needs at least version 1.6

I just flashed again the SD card. It is saying “Setting up ethernet connection failed”
I used the openHABian 1.6 32bit from https://github.com/openhab/openhabian/releases

The install guide tells you to read the debug guide so why don’t you do before posting ?

1 Like

I have done so. It is saying as well in regards to trouble shooting. “Do not hesitate to ask for help on the openHABian community forum !”. But all good. I do not know why but it is working now.

Mind the posting rules next time, please

1 Like

RPi 3b+
Openhabian 1.6
XFi ISP

Background: I went to update my OS and openhab installation on my RPi that has been working for over a year (probably closer to 2 years). Somehow, between the two updates the system got totally hosed. At the time I figured there may have been some incompatibilities. At any rate, after fighting with it for awhile, I got tired and put it away for awhile, figuring I would just reimage and start over.

Over the past couple of days I have been trying to get it to run. I am running into the same issue, no IP address assigned by DHCP.

It is a clean base installation. The only things connected to the RPi are the power, ethernet, TV (so I can see what’s going on), and a USB keyboard.
I have tested all the physical connections and they are fine.
My PC (static) and other devices (DHCP) all function normally.
Seeing as how my RPi wasn’t getting a DHCP address (169.254.0.10), I configured it for a static address. The static address shows up in ifconfig -a, but still no connection to the router. I ping the router from the RPi: device unreachable. I ping the RPi from my workstation (Fedora): device unreachable.

I have been reading forums for the past 3 days.

  • Some have this issue with no resolution.
  • Some have it, but turns out to be a hardware issue (new devices). I know this isn’t my issue because it has been working for 2 years, and I have tried 2 different RPi boards - same problem.
  • Most are not even closely related.

I have come to the conclusion that there has to be something in the new Openhabian release. I don’t want to use WiFi as that defeats the purpose of a closed network.

Any ideas? Thank you in advance.

Todd