No item-state update for Homematic IP contact interface HmIP-FCI6

Tags: #<Tag:0x00007f61732601e8> #<Tag:0x00007f6173260080> #<Tag:0x00007f6173273ec8>

Hello all,
I have problems in using the Homematic IP contact interface in openHAB.

The hardware is this: Contact Interface Flush-mount, 6 channels (HmIP-FCI6)
(german description)

I am using RaspberryMatic (3.47.22.20191026) on a RPi3, and OH 2.4.0 Release Build on a second RPi3 (openhabian). Both work together like a charm, with approx 30 HM devices, most of them classical Bidcos, but also some Homematic-IPs.

The exception are two HmIP-FCI6. From RaspberryMatic everything is fine, state changes are visible there, but not in OH

My Thing file (clip):

Bridge homematic:bridge:raspberrymatic [ gatewayAddress="192.168.100.101" ]
...
Thing HmIP-FCI6       001F1A********    "Kontakt 6x KG Garten" @ "Keller"

Items:

Contact  KONTAKT_K_KellertuerRoh "KellertĂĽr roh [%s]"          <door>    {channel="homematic:HmIP-FCI6:raspberrymatic:001F1A*******:1#STATE"}
Contact  KONTAKT_K_KellerSchloss "KellertĂĽr Schloss [%s]"      <lock>    {channel="homematic:HmIP-FCI6:raspberrymatic:001F1A*******:2#STATE"}
Contact  KONTAKT_K_Pumpe         "Pumpe  [%s]"                 <water>   {channel="homematic:HmIP-FCI6:raspberrymatic:001F1A*******:3#STATE"}
Contact  KONTAKT_K_FensterGruen  "Fenster GrĂĽn  [%s]"          <window>  {channel="homematic:HmIP-FCI6:raspberrymatic:001F1A*******:4#STATE"}

None of the state changes that I see in RaspberryMatic (RM) is visible in OH, and there is no clue in openhab.log or in events.log.

A strange thing that I noticed: After restarting OH the state of the items changes from NULL to CLOSED (independent from the real position); thats the only occasion that “something” happens to the item. AFAIR a non-numeric item is not persisted in RRD4J, so this “CLOSED” should come from RM?!

Any ideas?

Thanks,
Phil

Seems related

I don’t know if I understand the linked issue, but if I replace the item type from “Contact” to “String” the log file gives (filtered; the item here is not one of the example from my first post…)

... [ERROR] [pse.smarthome.core.items.GenericItem] - Tried to set invalid state 0.0 (DecimalType) on item KONTAKT_K_FensterVR of type StringItem, ignoring it

... [ome.event.ItemUpdatedEvent] - Item 'KONTAKT_K_FensterVR' has been updated

A physical change of the windows position does not fire anything in OH.

Will play with a workaround via the virtual remote buttons of the CCU/RM…

Thanks,
Phil

@shuhhi Have you found a solution? I am experiencing exactly the same issue, just with the HmIP-FCI1. I just dont reiceive any state updates…

Hello Kevin,
as mentioned, I am using the virtual remote control, that is offered by RaspberryMatic (I am sure that this is 1:1 available in the CCUs).
A program in Homematic is sending a “Short press” at the virtual remote, as soon as an input of the FCI6 is activated. The remote’s channel is then visible in openHAB.

Program to forward a state change of an HmIP-FCI6 channel via a virtual remote control to OH:
(sorry, my WebGUI is set to german, but I believe one can guess whats meant)


“Bedingung” is “Condition”
“Aktivität” is “Activity” (or whatever the english GUI uses :thinking: )

I was also facing similar trouble with a HmIP-WRC6 (six channel push button device). Here I implemented a script in RaspberryMatic that actually has no output, but only all the inputs from the device. It seems, that each of these channels has to be used at least once in an HM program. Only then it is forwarded to openHAB.

Program to force sending key presses to OH (for HmIP-WRC6):

Hope that helps
BR Phil

1 Like

Works like a charm. Thanks!

Hi @shuhhi

I have a HmIP-SRH and I am also missing the events for the sensor in OpenHab. Now, I tried to do the same for the channel, but I didnt get it to work. Any ideas?

Hello Stefan,
yes, I have a solution for you: get rid of HmIP and stick to classical Bidcos HM.
While my solution attempts did work for some time, they fail to be useable after some days or weeks.
I noticed that all issues I have with Homematic devices happen with HmIP, even those who worked without any workaround:
FCI6 contact interfaces, the WRC6 wall mounted button board, two thermostat valves: all refuse to send data after a while.

I don’t want to blame it to the devices alone; RaspberryMatic might be involved as well, but I don’t have the expertise to verify.
So I will replace the IPs with Bidcos or ZigBee…

Still, if someone got further ideas I am willing to give them a try.

Good luck
Phil

Thats not a solution but a frustrating report of your own attempts :wink:

The states are received correctly in HmIP CCU2 but not propergated to openhab…

Updated workaround: I installed RedMatic (a Node Red implementation for the CCU3; some documentation in german) to my RaspberryMatic, and here I can forward Homematic states via MQTT.
That allows me to continue using my unloved HmIP-devices.

HTH
Phil

In the meantime I found the solution. It was my fault. :wink:

The item configuration was declared as a Contact Type, which simply does not match the Channels type of String. So sorry for the confusion: The HmIP-SRH works perfect, even without a program as shown about.

I have now updated from the piVCCU 2 to a native CCU3 on RaspberryMatic (separate RasPi). After this migration, I have again troubles with the HmIP-WRC6 Buttons. Even though I have the dummy rules present, the events are not propagated to OPENHAB.

Any ideas?