No MQTT binding in OpenHAB 2.3?

I am trying to setup OpenHAB 2.3.
System: ubuntu 64-bit PC, java version 1.8.0_181
Below image is the screen shot of OpenHAB paper UI (could’t find MQTT binding)

I already enabled the legacy add-on option in the Configuration > System > Add-on Management
Am I doing any thing wrong or missing any step?

Turn on “Access Remote Repository” in Configuration > System

That option is also enable

Unrelated: I’d turn off the Include Legacy 1.x Bindings option to avoid confusion

Then the next step is to press the refresh button in top right corner of the Bindings tab to make sure it’s pulling a fresh list. I noticed that sometimes the menu in OH don’t refresh correctly and clicking that helps it refresh.

You might need to install the openhab2-addons-legacy package
(well enabling access to the remote repo as proposed might also offer all 1.x bindings for use, but I haven’t tried).

initially it was turned off.
And instead of refreshing, I restarted the OH service(logout from the OH terminal using Ctrl-d and run the again).

I have downloaded the legacy-2.3.0.kar file and moved it to openhab2>addons folder and restarted the OH service. Is there any other step?

No, MQTT is a 1.x binding so you need this to be enabled.

Not sure, if you want to do it manually you should cross-check with the package’s postinstall script.

If that still does not work, you might want to try it on CLI, i.e. edit /etc/openhab2/services/addons.cfg.
You would need to list mqtt1 as part of the bindings line.

No you don’t That option is confusing. That’s for bindings for which there is a 2.0 Binding available to still show the 1.x binding.

There’s no 2.x binding for MQTT. So it will by Default still show up.

I think tebore is right…

In the another post, it says that legacy bindings only available when package is set to expert mode, so, I will try that and let you know…

I was using standard package, changing package to Expert mode solved the issue (Without changing any thing in Configuration > System).

I’m on 2.3 and I do use MQTT installed via PaperUI. I have Remote Repositories selected but NOT legacy bindings ( which are IMHO only needed if you want to use a OH 1 binding for which a OH2 version exists).
Why the MQTT doesn’t show for you I can’t say ATM.

As I mentioned I was using std. package, that was the issue after changing to Expert package mode solved the problem.

Which package mode you are using?

Dear all,
I did not see MQTT bindings because my package was set on “minimal” mode. Changed to “standard”, rebooted and the “binding-mqtt1 - 1.12.0” package was shown. Also “Include Legacy 1.x Bindings” was on.

Good, please mark the thread as solved, thanks