No openHAB 3 UI in Android App (only white page)

Dear all

I have some issues using the openHAB Android App on a Samsung S20 with Android 12.

I can set up the remote connection through myopenhab.org in the app and it will work just fine once. Then it will only load the sitemap, never again the openHAB 3 UI view. Just a blank white page comes up instead of the overview page and does not refresh. Restarting the app does not help. Only uninstalling and the re-installing will help. It will then work once to display the UI, then never again. That is quite annoying.

The mobile is connected via 5G network and has full internet access.
I found this thread here, but there is no solution in it:

I am running OpenHAB 3.3 (release version) and using the latest update of the openHAB Android app. I have also updated the WebView Tools on my mobile and also tried to change them with the latest “dev” version. Still only a white page instead of the openHAB 3 UI

Does anybody have some hints for me? Can it be a problem with myopenhab.org? But why should it then work once just fine?

Thanks

You can try to unset the country setting in the OH regional settings.
It was until recently the working workaround for me.
PS: Just tried with my current 3.4 snapshot and seems to be no more required.

I have the same issue also with a S20. Only the beta version of the app is working for me. Maybe worth to try… (Not sure what exactly has changed in the beta version and why it’s working)

I have tried the beta version as well as the released version with no success.
A few months ago I managed to get it all working well. Charts etc all working.

Then suddenly it just stopped again. I can get a Sitemap, but no openHAB 3 UI. Just the white screen.

MyOpenHAB also works fine.

There are quite a few threads along this line, but no working solutions that I have been able to find.

Also not working for me s22
Has been fine for years and the last 5 or so days no more

Has anyone figured out any solution on this? I am experiencing similar on both S20 and S22. One thing I discovered playing around on one of the affected devices. Stable release 3.0.1 replicates the issue but version 2.23.11-beta works as it is supposed to (both downloaded directly from Github). I am not sure what is the difference between the versions as I would expect them to behave the same as the release should just be the final version. I use a S10 myself without issues so seems to be something with the later versions.