No Sitemaps available after latest upgrade

Hello everybody,

after upgrading from the unstable Debian packsge 2.1.0~20170422041239-1 to 2.1.0~20170430040301-1 (haven’t tried the in-betweens), it is not possible to interact with OpenHAB2 any more via sitemaps.

I have two sitemaps defined in my configuration directory (one is just an item for group All to show all devices), but the BasicUI says (picture from another thread which shows the same, but there was it seems a problem with configuration), while to me this happened from a running and working instance:

Before it worked flawless. Interestingly there is also no output in the log - no Exception - nothing. When I change the .sitemap file it usually logged that it’s reloading the sitemap, but even that’s not happening. It seems as if it does not even try to load the sitemaps.

Hope this helps to fix the issue, soon. I’ve posted it here, as the many project on GitHub confused me and I wasn’t sure which one would be the appropriate.

1 Like

I have the same issue after upgrade

I removed the old version and installed openhab snapshop. Still nothing in sitemap. Looks broken to me. Any ideas?

Post your *.sitemap file contents here to check it
Use triple backticks:

`<contents here>`

to post the file contents.

Also, check in your PaperUI->Configuration->Services->BasicUI->Configure the name of the Default Sitemap

Alternatively, you can access your sitemap with:


here is my sitemap.
It works ok in beta and stable release

sitemap gate label="Main Menu"
	Frame label="Controls" icon="first floor" {
		Switch item=boiler	 label="Boiler"
		Text item=boiler_LastUpdate label="Boiler last update"
		Switch item=outside_light	
		Text item=outside_light_LastUpdate label="outside light last update"
		Text item=outside_temp icon="temperature" {
			Chart item=outside_temp period=D refresh=6000 
			Chart item=outside_temp period=W refresh=6000 

Does this work?


Also, is “gate” set as the default sitemap in BasicUI?

nope. tried if first time

some syntax errors exist

Use ESH Designer (0.8) to debug

1 Like

thanks you. fixed it now

1 Like