NodOn Enocean Smart Plug MSP-2-1-11 not discovered (EEP D2-01-0E)

Hello together,
I just bought the above smart plug (for the christmas tree ;-)), but I cant get it included in Openhab 4.0.4. Just updated my openhabian (running on Raspi 4 with EnoceanPi-Module).

The log shows:
2023-12-14 22:07:15.210 [INFO ] [ernal.transceiver.EnOceanTransceiver] - Received teach in message from 05A1454F
2023-12-14 22:07:15.212 [INFO ] [covery.EnOceanDeviceDiscoveryService] - EnOcean Package discovered, RORG UTE, payload D4A00146000E01D205A1454F01, additional 01FFFFFFFF4400
2023-12-14 22:07:15.215 [WARN ] [covery.EnOceanDeviceDiscoveryService] - Could not get new SenderIdOffset

Any idea how I can light up the tree?

Thanks a lot,

Hi Heiko,
if auto discovery doesn’t work you can still try to add it manually.

Have you tried that?

Hey there,
it seems like you try to teach in the plug into OH. I don’t think this is how it works.
Do you see any EnOcean ID on this device?

The Teach in command is used to teach in the device into another EnOcean device. Which is not the case here, right? :wink:

Edit: According to the log the EnOcean ID might be 05A1454F. Do you see this ID on your actual device or the box it came in?

Teach in is the way it normally works.
You can add things manually, but the teach in should work.

Start discovery, press the teach-in button of the actuator/sensor, the thing should be created.
See here:

It looks the SenderIDOffset is the problem. This number can be chosen manually or the next free/unused number can be determined by the binding.

I think adding the thing manually should work.

Hey Dirk and Sebastian,
Thanks a lot for the ideas.
I tried again to add it manually. Then there is the message: “could not get a free sender-id from bridge”.
I tried with id 127. No success. So I roughly counted my enocean devices. I have 64 things. So I used sender-id 70. Then the thing could be included and it went to “online”.
Now if I switch the switch manually on/ofd on the physical button on the plug, i can see the status changes in OH. But if i push the OH switch, then the plug dont show any reaction.
Any further hint?
And any idea why auto-discovery disnt work?

Thanks a lot,

Which Channel do you use for switching in OH?
Just to be safe: You have to link an item to the switch channel. Don’t use the teach in channel.

Ok, now you successfully teached in the plug into openhab so that you can see the state.

Now you have to teach in your openhab switch into your plug.
Bind a switch item to the teach in channel from your openhab thing.
Turn on the teach in mode at the plug and toggle the teach in switch item.

1 Like

Hey both,
Thanks a lot.
Sure I use the “switch” channel. And this device also dont have a “teach-in channel.
Really a bit strange…
Just one came to my mind: for sending EEP I use he same as for receiving, right? Both times the D2-01-0E.
And as i can see the status changes in OH when i press the button on the plug, I would assume that the teach-in into the plug went wrong? Or?

If you can see the state in openhab, the receiving EEP appears to be correct.

I would assume that the teach in into the plug wasn’t done correctly.
Unfortunately I don’t own any of these nodon devices, so I can’t test how to do it the right way.
Maybe you can try with a physical wall switch to control the plug? If this works you can teach in a openhab rocker switch thing.

Hey together,
I just tried with an enocean wall switch. Works smooth. Can teach in and switch on/off.
But I have no idea what to do that OH can work too. :frowning:

When you put your plug into teach in mode (the same way you did it for the wall switch) and then you toggle the switch item it won’t work?
Maybe there is a bug for this device in openhab.

You can try to add a classic device or rocker switch (F6-02) thing in openhab and learn it into the plug, to simulate a wall switch. Maybe this will work.

Dear enocean users
Unfortunately the MSP is not supported from the plug-in. See New openHab2 EnOcean binding - #1084 by execcr?

Hello together,
thanks for all your help.
I managed to use it with “Energy measurement switch” (EEP D2_04_0e) for the plug and an additional “Classic device” (EEP F6_02_01) which is linked with the plug. It´s not nice but at least functional.
Hope someone with the related knowledge and time can implement the correct stuff some day. :slight_smile:
Best regards,

1 Like