Noob only wants to switch it´s Intertechno actors

Hi there,

I “only” want to switch my Intertechno actors.
For that, I want to use a Transmitter like explanined here.
I installed WringPi and Raspberry-remote.
Wenn I paste th code

sudo ./send 11111 1 1

the error

sudo: ./send: command not found


I also tried this Tutoria. The commands

make send 
make codesend

don´t work either.

I installed the intertechno binding, but I don´t know what to paste in the culintertechno.

Is there anyone who can explain me step by step, what I have to do?!


When you copy paste this line you have to either be in the directory which contains send or specify the full path.

The tutorial is sequentially, so you have to follow it step by step. Which would have placed you in the right directory. As you compile send before testing.


[13:24:12] openhabian@openHABianPi:~$ cd SourceCode
[13:24:14] openhabian@openHABianPi:~/SourceCode$ cd 433Utils/RPi_utils
[13:24:30] openhabian@openHABianPi:~/SourceCode/433Utils/RPi_utils$ make send
make: *** No rule to make target '../rc-switch/RCSwitch.o', needed by 'send'.  Stop.

Where is my fault concretely - I´m noob

Go to the root of the project :~/src/433Utils/ initialize the depending submodules and update them.

git submodule init 
git submodule update 
cd RPi_utils/
make send


[14:11:55] openhabian@openHABianPi:~$ git submodule init
fatal: Not a git repository (or any of the parent directories): .git


[14:12:45] openhabian@openHABianPi:~/SourceCode/433Utils/RPi_utils$ git submodule update
Cloning into '/home/openhabian/SourceCode/433Utils/rc-switch'...
Submodule path '../rc-switch': checked out 'c5645170be8cb3044f4a8ca8565bfd2d221ba182'
[14:12:57] openhabian@openHABianPi:~/SourceCode/433Utils/RPi_utils$ make send
g++ -DRPI   -c -o ../rc-switch/RCSwitch.o ../rc-switch/RCSwitch.cpp
g++ -DRPI   -c -o send.o send.cpp
g++ -DRPI  ../rc-switch/RCSwitch.o send.o -o send -lwiringPi -lwiringPiDev -lcrypt

Not root root of the git project. :wink:
But you got it figured out.

It goes on:

sudo -u openhab src/raspberry-remote/send 10010 2 1

returns the error:

sudo: src/raspberry-remote/send: command not found


Please try to adapt your path to where your program actually is.

Maybe use the absolute path /home/openhabian/... to avoid such problems.

You should have a look here

This line you posted expects you to be in the folder where the folder src is in, as it is a relative command.

Think it would probably run…
But my plugs are selflearning (IT-1500), so they have got 26 Bits.
Like explained here.

I tried to send the code:


But the answer is:

Sending 433 MHz remote plug control codes, hardcoded on wiringpi pin 0.
Usage: ./send <systemCode> <unitCode> <command> [pulseLength]
systemCode  - First five settings of Type A 10 pole DIP switch, e.g. 11111
unitCode    - Switch number [1 .. 5] or [10000 .. 00001]
command     - 0 for OFF and 1 for ON
pulseLength - optional pulse length

I don´t understand the Intertechno Binding either, because there is no explanation for noobs - how ever

intertechno can not be switched with the send comand from 433Utils which uses this sheme:

<systemCode> <unitCode> <command>

Intertechno uses this:

<houseCode> <groupCode> <deviceCode> <command>

You could sniff the codes and use codesend from 433Utils as explained for the LED stripes in the tutorial you posted above.

Or use an adapted code which enables the intertechno sheme.

Tried to sniff the Codes with wiringpi - unsuccessful.

Try your version and pilight over the week.
I´ll give an update