Not able to change codes on Yale lock (YRD446)

I have been using my lock with the 2.3.0 development version of the z-wave binding for a while now. I can never get it to save the user codes with HABmin. It always corrupts all the currently added codes so that they don’t work at all, and requires me to erase them all and manually add them through the lock’s keypad.

I recently switched to the 2.4.0 development binding and have the same problem.

I would like to be able to add the codes remotely, but it has never been able to work. Has anyone else been able to get codes to work with a Yale lock?

Hi Brent did you solve this issue?


Nope. I have just been manually adding and removing codes on the lock itself. I even tried it with org.openhab.binding.zwave-2.4.0-SNAPSHOT.jar. That is the version I am using now, and it still did not work. I had to remove all the codes and manually add them myself again.

I have never had this problem with these locks with the SmartThings hub. But I absolutely hate how dependent on cloud processing the SmartThings hub is.

Have you tried the 2.5 development binding?

Nope, not yet. I don’t even really know where to look for it, because you have to make sure that you download the version with security enabled or it will not work with the lock at all.

Also it is pretty annoying to have to delete all your codes and manually reenter them after they get corrupted. And it is currently -10 degrees fahrenheit right now, so there is no way that I am about to risk having to manually add codes with my front door open.

Fair enough! The development version has Security enable from what I’ve read.

Security is now in the snapshot version. Latest available can be downloaded from here…$org.openhab.binding.zwave/

1 Like

I tried the latest version and it deleted a few of the codes from my lock. Some of them remained, but I decided to wipe all the codes and manually put them all back anyway.

So it still does not work properly and not even close to reliable enough to be usable.

Odd. Did you make Chris Jackson aware? @chris as I believe there are other users using your lock just fine.

I haven’t done anything other than try the Z-Wave modules as they get released.

I haven’t tested it recently, but user codes have been working fine with a BE469 though Habmin or the REST API. The only trick I recall was that they had to be added/removed in order. If you add one with a gap in the slots betwen it and the previous one, or remove one from the middle, the codes got corrupted. Does this sound like the problem you are experiencing?

It could be. I really don’t remember. I usually just try to add or remove a code. If I have to remember to do it in some kind of order, then it isn’t really worth it to me to have the ability to do it that way anyway.

Can you provide a log showing this - it should be completely independent (although it’s been a year or two since I looked at that code!).

It may be a couple days, but I’ll get you one. I’m also curious what happens to the codes when one is removed manually from the lock… do they shift slots, are there gaps, etc.

BTW, I sent you another log for that open ticket.

I wouldn’t have expected them to change - it should just get marked as free. If they are changing, then that could cause problems, but I would be very surprised as it would screw up a lot of systems I think. The code ID is used to identify users in some cases - if all the IDs changed when one person was removed, it would be a mess.

Yep - I say that and will take a look when I get a chance. I had/have some ZigBee stuff that I needed to get out over the weekend and I hope I can finish that tonight.

1 Like

I am pretty darn sure that is the way it is supposed to be, and you are supposed to use labels of some kind that keep track of the slot numbers for you to actually track what slot is using what code. From the sounds of it, I imagine the lock code management needs a significant upgrade to allow for this kind of functionality. I think that is exactly how most other lock managers are handling the codes for this kind of lock. I know for sure that is how SmartThings does it.

The problem is that there is no such concept in OH, so it doesn’t need an upgrade - it needs defining from scratch. Th binding provides the means to set the codes, but we then have to shoehorn the interface into the existing UI which is a bit of a mess.

If setting the codes doesn’t work, then I’ll take a look if you provide the logs etc - it certainly used to a year or two back, but I’ve not tested it myself for a long time.

1 Like

You sure about that? I started with openhab about a year or two ago and had this lock at that time. I have never been able to get it to work with user codes correctly. I started with the z-wave 2.3.0 module and then tested 2.4.0 and now the 2.5.0 that still do not work. Maybe it was working with 2.2.0 but I would not know.

Absolutely 100% sure.

I still don’t know what your problem actually is? Can you provide logs showing the problem, and a description of what you think it happening?

2.2 didn’t have security.

I don’t have logs, but everything else for the lock it working other than changing settings in it.

When I try to add or remove a code then most if not all of the codes get removed. It may be that I need to add and remove the codes one at a time in order of last to first like someone else suggested, but I have not tried that yet.

I will give that a try some day, but I really don’t like having to manually add codes back to my lock once they have been corrupted.