Not getting any Z-Wave Messages from NanoMote

exclusion (node 4) and inclusion (node 8) log.log (416.7 KB) Hi, i’ve installet a Aeotec Z-Stick and some nodes on OpenHab 2.5.3 with org.openhab.binding.zwave-2.5.5-20200504.110626-5.jar
But I really have problems getting Aeotec NanoMote Quad ZWA003-C to work.
I added it to the Network, it shows in Things, but no changes happen to SceneNumber when I press a button.
Also the batterylevel didn’t update after a day (near the controller).
zwave DEBUG is enabled, but there are no messages when i press a button.
Tried also to set Parameter 1 Controller
I have the inclusion log
What am I doing wrong?

Somehow z-wave binding is getting the scenes now.
A new problem came up now:
On Button 1 i get scene 1.0, and a Roller Shutter 3 is moving, but I don’t know why.
I tried to remove everything from Association Groups.
There is no rule either acting on the scene number or the Roller Shutter.
Is there anything else that may transmit commands?
Or may there be a bug in parameter settings (on both?)?

Did you wake up the remote after fixing the association groups? If you didn’t do a manual wake up then the remote won’t show any changes until the next automatic wake up.

But, other than the channels there should be nothing else passing information. Do you have anything connected to the remote’s switch_dimmer channel?

I tried several times to wake up, and it didn’t change.
I also have issues with getting updated infos on the Roller Shutter 3 parameters.
I can’t find the dimmer-item anywhere except from a sitemap and in userdata/jsondb.

I’ve found references to some nodes that don’t exist anymore.
Should i make changes in userdata/jsondb?

But this probably doesn’t cause the problem, as it even moves with Z-Stick disconnected from OpenHAB

I have the Aeotec gen 5 stick and a nanomote and I have not encountered these issues.

How are you adding the devices to your network?

Have you looked at the devices in Habmin? It’s z-wave functionality is slightly more reliable than paperui and more verbose as well so it may tell you something.

There are other opens for examining your network as well. I have found that OpenZWave Control Panel has been helpful for debugging a few times.

I believe you need to stop OpenHAB before running that though.

I stopped Openhab docker and created this:

docker run --name=ozwcp
-p 32008:8008

but i can’t get access to stick:

sh-4.2$ chmod 666 /dev/ttyACM0
chmod: changing permissions of ‘/dev/ttyACM0’: Operation not permitted
sh-4.2$ ^C
sh-4.2$ ls -la /dev/ttyACM0
crw------- 1 root root 166, 0 May 14 11:58 /dev/ttyACM0

I added them with Openhab, some in PaperUI, some in Habmin.

Only root has access to that device. That is not normal in my experience. I think the dialup group? normally has access too.

In the openhab container it’s the same.
I have to do chmod 666 every time i start openhab …
So the “not permitted” message depends on the container.
I’m on a QNAP TS-241D

Its the dialout group that should also have access to the stick

$ ls -la /dev/ttyACM0
crw-rw---- 1 root dialout 166, 0 May 14 09:41 /dev/ttyACM0

I don’t run docker, but I assume that the permissions issues are the same. You’ll need superuser rights to change the stick permissions.

sudo chown root:dialout /dev/ttyACM0

And then you’ll need to add your user to the dialout group

sudo adduser [yourusername] dialout
1 Like

You would also need to permit the dialout group to have read and write access. The initial state only permitted owner access.

sudo chmod g+rw /dev/ttyACM0

I can’t use any sudo in this docker.
I only get a: sudo: command not found
Tried with ruimarinho/openzwave, this works.
But I can’t find any association groups. Where are they supposed to be?

Usually you connect to your Docker container as root. sudo then is not needed.

openHAB does not use openzwave at all. I do not understand.

Ok, but as i said, I couldn’t enable rw permissions on z-stick.
I tried to get rid of a ghost association trying everything, finally i removed the NanoMote from the Z-Wave Network, and now I’m at the beginning again, not getting anything from NanoMote.
Now I’m tryint to find where i can configure the Network in Habmin, described here.
I can’t find that Configuration page.
Is there a URL i can use by changing the IP?

If you cannot get read-write permissions to the stick, nothing else will work until that is resolved.

I have read-write on the stick, there was only one docker container where it didn’t work.
Sorry if I wasn’t clear.
Can you please point me to that page in Habmin?

This page may work better.

I already have this working. I can control venetian blinds.
I have the NanoMote added in Habmin (but not getting messages anymore).

But there must be something messed up.
For example: For Json Storage Backup configuration

  • PaperUI shows 5
  • Habmin shows 0

And there are no errors in openhab.log

Can you please share the URL where you access the z-wave configuration, like:

When i try to edit z-wave things, i get:
ERROR: 500 - Internal Server Error

I switched back to 2.5.3, no more errors.
But i still can’t find the z-wave config in Habmin :cry: