Notice to all openHABian users: Please apply a fix asap!

Tags: #<Tag:0x00007faed4e6a8b8>

If you read this and own an openHABian powered system, please execute the Update function in the openHABian Configuration Tool now.
Thank you!


It was brought to our attention that openHABian systems cause requests spikes on remote package update servers. This is a serious problem we were not previously aware of. This unwanted behavior is related to a simple cronjob configuration mistake and the fact that the openHABian user base has grown quite big over the last couple of months.

Every openHABian installation is currently requesting package update information from update servers at 3:03am local time. With hundreds of openHABian installations in certain time zones, these individual requests reach the update servers at nearly the same time, resulting in a DDoS like bombardment of their service.

I have implemented a fix for this issue but have to rely on you, the end users, to apply it.

What to do

  1. Connect to your openHABian system via SSH/console
  2. Execute sudo openhabian-config
  3. Select “Update”
  4. Wait for the update to finish
  5. Execute sudo openhabian-config again
  6. You’ll be asked to apply the fix.

These steps are otherwise harmless to your openHAB/openHABian system.

Because the described problem effects other parties we want to resolve it as soon as possible and urge you to update and apply the patch as soon as possible!

10 Likes

Is there a way to do this update on windows

The discussed problem is related to the openHABian Linux setup many are using at home on their Raspberry Pi or other dedicated systems. It is not related to openHAB itself. If you are using openHAB on Windows or the Mac, or you’ve got openHAB set up on Linux by yourself, the “Urgent Fix” is irrelevant to you.

I have made the update on my rpi and when the system reboot i no longer can make any comands, for example “sudo openhabian-config” or no other commands. What to do?

Bad luck, this might be related to openHABian stuck on ssh connection

@Magnus the issue is resolved. Please follow the link to see how to solve it for you.

I tried to update but got a error message. Sorry I didn’t saved it. It stated something about my system is not located on a SD card (I have moved my system from SD card to a USB stick).
In the terminal I got:

2017-05-08_21:03:42_CEST [openHABian] Updating myself… fatal: The remote end hung up unexpectedly
FAILED - There was a problem fetching the latest changes for the openHABian configuration tool. Please check your internet connection and try again later…

Hi, i got the following lines after applying the update and then applying the fix…

2017-05-10_21:41:16_BST [openHABian] Checking for root privileges... OK
2017-05-10_21:41:16_BST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2017-05-10_21:41:26_BST [openHABian] Downloading and setting up FireMotD...
$ git clone https://github.com/ThomDietrich/FireMotD.git /opt/FireMotD
Cloning into '/opt/FireMotD'...
remote: Counting objects: 604, done.
remote: Compressing objects: 100% (37/37), done.
remote: Total 604 (delta 21), reused 0 (delta 0), pack-reused 567
Receiving objects: 100% (604/604), 1.73 MiB | 1.21 MiB/s, done.
Resolving deltas: 100% (352/352), done.
Checking connectivity... done.

$ /bin/bash /opt/FireMotD/FireMotD -S
W: GPG error: https://dl.bintray.com jessie Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 379CE192D401AB61
W: GPG error: https://packagecloud.io jessie InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 37BBEE3F7AD95B3F
OK
If you wish so. Bye Bye! :)

Is the GPG error of concern?

Hi @ThomDietrich,
for me the update works fine. FireMotD also works now…hope no UpdateServer will be harmed this night :grin:
Schönes Wochenende
ChristianH

1 Like

Hello @Roscoe_Gray, yes that’s of concern but unrelated to the update.
Your apt repositories are not properly set up. Please import the respective public keys.

  1. http://docs.openhab.org/installation/linux.html#package-repository-installation
  2. Depends on where it came from. Please check your /etc/apt/sources.list.d/
1 Like

Maybe a stupid beginner question. On my RasPi console there is no openhabian-config command.

You would have it if you would have installed openhabian. Maybe you did install openhab on your on your pi which hab already an os on it. In this case you don’t have that.

To be honest, i’m not realy understood the answer.

I have installed openhab2 on raspbian operating system. There is no command openhabian-config available.

What to do?

Since you have not installed openhabian (which is a package of raspbian plus openhab) your system does not have this command and this thread does not apply to you.

1 Like

Friend I installed all now openHABian no longer sees my sitemap file despite this is existing … error … not found sitemap