NZW37 from Inovelli not a recognized Z-Wave device

I purchased an Invoelli dual switch that says it’s Z-Wave certified. When it arrived, the unit says it’s only certified for certain hubs/gateways. It calls itself an NZW37, which is apparently a new version of the ZW37. Unfortunately, it’s not being recognized. Its properties are listed below. Can someone point me to the proper method to add this device so it’s recognized in OpenHAB? Is this something that Chris Jackson has to do? I found an old post referring to the ZW37. The device looks the same but is apparently different internally.

zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SWITCH
zwave_frequent false
zwave_neighbours 1
zwave_version 20.17
zwave_listening true
zwave_plus_devicetype ON_OFF_POWER_SWITCH
zwave_deviceid 9500
zwave_nodeid 3
zwave_routing true
zwave_beaming true
zwave_class_specific POWER_SWITCH_BINARY
zwave_manufacturer 786
zwave_devicetype 45601

Register first, then email Chris to get edit rights, upload your xml to the database (make sure it’s different from the ZW37, sometimes only adding a new version to the existing one is needed), wait for device approval, update zwave binding to the latest snapshot and you should be good to go.

Thanks, There seem to be problems on the site at the moment. I emailed him and I’ll try accessing the site again later.

From the error you sent, this is likely a database backup issue. The database is backed up every 2 hours, and when this happens (at 15 minutes past the hour) it’s offline for a few seconds. I see no problems with it at the moment.

Yep, thanks. It looks like I just had some poor timing.

I bought a NZW37 this week, and am having the same problem. My device also has the
zwave_manufacturer 786
zwave_devicetype 45601

This is my very first Z-wave device. It seemed like a good starting point to learn Openhab before I drop big $$$ on pool automation. It seems my timing and device selection were unlucky.

I definitely appreciate all the work the community has put into Openhab and the various addons. Clearly a lot of people have spent a significant amount of time trying to make a complicated thing easier to use. Hope this gets added to the database soon.

or upload your xml (in /userdata/zwave) to this post and I am happy to add it.

Here it is. Greatly appreciate the help in advance. This is the NZW37 from Inovelli, the Amazon page notes “This is the same great plug as our prior Show Home model – we swapped the logo and upgraded the firmware to allow you to turn off the LED light on the front!”

node2.xml (13.3 KB)

That manufacturer is not even in the database and I cannot add it.
We need to ping @chris to solve this if he is not to busy with other stuff :slight_smile:

I’ve added this - any issues, just shout :slight_smile: .

OK, the device has apparently been added – but how do I get it to load into OpenHAB now? I thought I read in here somewhere that apt-get update was supposed to pull in the changes, but I did that, deleted the unidentified thing, rescanned and it still comes in as an unidentified device. What am I missing? Thanks…

You can get the latest binding by uninstalling, and re-installing the binding from PaperUI/HABmin - so long as you are using the snapshot version.

Note that if this was only added this morning it won’t have been built yet so you might want to wait an hour or two more…

I uninstalled and reinstalled and I still don’t see the NZW37 in the list and my device is still unknown.

Z-Wave Node 3 (0312:B221:251C:20.17)

How do I tell if I have the “snapshop version”? I don’t know what that means. If I don’t have that version, what are my options?

Thanks, Tim

Easiest way is to log into karaf console:

                          __  _____    ____
  ____  ____  ___  ____  / / / /   |  / __ )
 / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  |
/ /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ /
\____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/
    /_/                        2.2.0-SNAPSHOT
                               Build #975

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'system:shutdown' or 'logout' to shutdown openHAB.

It will tell you the openHAB version and build number.

On the console do a bundle:list and look for a line with zwave:

9 | Active | 80 | | ZWave Binding

There you can see the exact build date of the zwave binding. It should be a very recent one to get NZW37 to work.

“Apparently”? Who actually added the device? I can’t find it in the database and there are no devices listed under Inovelli by the looks of it…

Maybe that statement was misinterpreted? I too thought you already added the device, not only the manufacturer, sorry.

But NOW it is added:

Ah - ok. Someone asked for the manufacturer to be added - so I did ;).

1 Like

Hmmm, when I went through the process to upload the XML file, I got a message leading me to that conclusion. I don’t recall exactly what it said since it’s been a while since I tried. I guess I can try again and see what happens.

I also saw that someone replied to one of the chains stating that they were going to upload it and it seemed that they had beat me to it.

Well, it seems that I’m on “openHAB 2.0.0-1 (Release Build)”

And “bundle:list” by itself says “command not found”. Is that a qualifier on a command that is not ringing a bell at the moment? apt-get doesn’t like it.

OK, thanks – I thought I saw that someone had added it.

But I’m not on the snapshot build. I’m on a release build. Any info on what I need to do to pull these changes down?