Official Alexa Smart Home Skill for openHAB 2

sorry guys, no way to make it works. followed this https://github.com/openhab/openhab-alexa as well this https://heathpaddock.com/2017/02/02/making-amazon-echo-alexa-sing-to-openhab2/ guide. situation is:

my own openhab cloud instance
italian localization
echo dot 3 into the same network of my openhab installation (on RPI3)
items correctly formatted. tags are ok
aws seems ok, alexa seems ok
oauth is ok

from my smartphone, with amazon alexa app installed i configure the skill -> ok- > login & password -> ok -> search devices -> echo dot3 starts but blinking blue -> no way to find items.

i’m going crazy, billions of retries but no success
any help, please?

I just got this running last night on a similar environment. It was a bear to get going, but I have everything fresh in my mind, maybe I can help.

I suggest checking the lambda logs first in amazon cloudwatch and posting those results. The URL will be different based on how you set things up, but you can find them by logging into https://console.aws.amazon.com.

Finally i did it!

It was about alexa’s skill configuration: defining oauth url for authorization and token. Urls must be about own openhab cloud instance, while client id and secret must be the ones generated as described into guides. The step was missing is that is needed to add client id and secret into mongodb of cloud instance as well. See the google home guide for how to do this. Once did this step, my echo has been able to corretly find openhab items

Finally i did it!

It was about alexa’s skill configuration: defining oauth url for authorization and token. Urls must be about own openhab cloud instance, while client id and secret must be the ones generated as described into guides. The step was missing is that is needed to add client id and secret into mongodb of cloud instance as well. See the google home guide for how to do this. Once did this step, my echo has been able to corretly find openhab items

inviato dal Pecofono

How can I tell Alexa to turn the thermostat off?

“Alexa, turn the heating to 22 degrees” - > “Thermostat heating is set to 22 degrees”
“Alexa, switch the heating off” -> “Thermostat heating does not support this”
(from German)

Can anyone help? Please check Thermostat works well in Google Home, but not with Alexa

I think that in my neighborhood the thieves would just throw the loudspeaker at a window :wink:

Hi,

Could someone please post an item example using v3 tags and a binding. Or confirm my guess below.

I see that the V3 tags are done like this:

Switch LightSwitch "Light Switch" {alexa="PowerController.powerState"}

but if I also have a binding channel connected to the item is it then like this with a comma between? :

Switch LightSwitch "Light Switch" {alexa="PowerController.powerState", channel= "........."}

Thanks Mark. I would test but I am not near my openhab setup at the moment

1 Like

Hi there,

i have also the problem that devices are not found by Alexa. I have done the following steps:

  • tag my items with “Lighting”
|Switch  SZ_Tradfri_Bett_Rechts_Toggle       |<light> ["Lighting"] |{ channel="hue:0100:XXX:SZ_Tradfri_Bett_Rechts:brightness" }|
|Dimmer  SZ_Tradfri_Bett_Rechts_Dimmer       |<light> ["Lighting"] |{ channel="hue:0100:XXX:SZ_Tradfri_Bett_Rechts:brightness" }|
  • Activate Alexa Skill (myopenhub shows the connected Alexa application)
  • Add items to the expose line of the Cloud connector (items are shown and updated at myopenhub.org)
  • Checked myopenhub.org/rest/items -> items are there, takes around 3sec to get them
  • Search for Devices with Alexa -> nothing found

What should I do next?

Bye
Nino

@TheLexus My guess is that your items need to be labelled.

Where did you get the | from? this is not part of items configuration!

Switch  SZ_Tradfri_Bett_Rechts_Toggle "Schalter"      <light> [ "Lighting" ] { channel="hue:0100:XXX:SZ_Tradfri_Bett_Rechts:brightness" }
Dimmer  SZ_Tradfri_Bett_Rechts_Dimmer "Dimmer"        <light> [ "Lighting" ] { channel="hue:0100:XXX:SZ_Tradfri_Bett_Rechts:brightness" }

Thanks, that was the simple fix!

Is this skill the preferred way over the hue emulation? They seem to do the same, did I miss something?

Where is this file on the windows version? Run 2.4

Today I worked on my thermostate again. Still, I cannot set the modes as written above. Plus, in the Alexa app, the thermostat is not properly recognized.

I opened a discussion on this here - please help: Thermostat works well in Google Home, but not with Alexa. Thanks!

Thanks Zolakk. This worked…

Hi

I’ve got a Danfoss CC link thermostat system running in my house, which is great but there are no open APIs to interact with it from systems like OH.
Danfoss has recently opened up for Alexa though to use it’s closed APIs, but that requires an Alexa in your house, which I don’t have as of now. Apart from being able to use OH to control the temperature, I’d also like to monitor the room temperatures without having to ask Alexa all the time…

My questions are:

  • Can you setup a rule that mimics a voice interaction so the monitoring can be done on a scheduled basis and so Alexa can be used as a bridge to devices with no OH binding?
  • Is it possible to bind OH items with an Alexa account without actually setting up an Alexa? (My lack of Alexa knowledge shines through here…)

AFAIK, I don’t think there is another way, currently, to control an Alexa skill than by voice directly.

By Alexa, you mean an Echo device, you can certainly enable this skill and bind OH items to your Alexa account without owning one of these devices. You can use the Amazon Alexa phone app or the echo simulator to interact with your configured devices.

Hi All,

I just found the latest (v3) documentation of the Amazon Alexa Smart Home Skill and decided to try since it seemed staightforward.

According to the doc:

This page describes how to use the openHAB Alexa Smart Home Skill. The skill connects your openHAB setup through the myopenHAB.org cloud service to Amazon Alexa.

I have upgraded my OH2 to the latest( 2.5.0-SNAPSHOT Build #1617) and simply picked up one of the examples and put into a new item file. There were no error but when I asked my Echo to discover there was not any new item found.
I have tried different type of setups, also restarted and checked any logs that came into my mind.

Is there any addtional setup is needed to enable the new(Alexa Version 3 API base) config style other than the item file changes?
Should it work with the Openhab Alexa skill via myopenHAB.org?
Any idea what can be the cause of the issue?

Thanks, Adam

Did you read this thread?

The v3 skill is still in beta testing. So if you are trying to use the current official openHAB Alexa skill, it only supports v2 tagging.