Official Google Assistant Integration for openHAB

Maybe? related to:

  1. Remote Access is slow
  2. Is home.myopenhab.org down?
  3. Long delay in rest command to myopenhab
1 Like

Just to let you know… It´s working like a charme! Again, thanks alot… I would never have figured this myself.

1 Like

I have kind of similar issues:

  • Google home was saying that it cant reach openhab
  • Myopenhab.org was reporting “Online” status and push notifications were working correctly, however remote access to dashboard via desktop (https://home.myopenhab.org/start/index) or Android app resulted in 504 gateway timeout or corrupted page (html without images and CSS)

So I tried:

  • Completely deleting myopenhab.org account + unlinking it from Google
  • Completely wiping openhab installation (apt purge openhab2) and reinstalling + restoring /etc/openhab2 folder from backup (git)
  • Reconfigure everything…
  • Linking openhab back to MyOpenHab.org
  • Linking MyOpenHab.org back to Google (after like 20 tries because of the stupid message “Couldn’t update the settings. Check your connection.”)

Everything seems to be working for few minutes and then I stared getting 504 from MyOpenHab again and Google was unable to reach openhab yet again…
In openhab logs is nothing - Very frustrating…

My friend (which is also running his home on openhab) is also reporting slowdowns between Google and his openhab instance - but just huge delays - it still works.

Is there any way for me to debug it?

Any one can give a status report on what is going on? And if we can help in any way?!

Thank you

1 Like

There is currently a temporary problem with the myopenhab.org platform that causes these timeouts
It’s a pity that you went through all this trouble to re-setup your system :frowning:

We are all expecting the issues to be resolved soon. The team is working on them as we speak.

Dan fixed it :slight_smile:

It’s working very fast now for me!

3 Likes

I have a problem with thermostat on Google Smart Hub. On Google Home android app the thermostat shows the mode (it is set using numbers: 0- Off, 1-Heating, 2- Cooling) correct. On smarthub it shows unsupported mode. I tried also with string to set the mode but it is not working. Do anyone have this problem?

Hi Marius,
I see the same behavior you are describin, but I wondered if it is not rather a Google home hub problem…

Marius, there are some bugs in the way the binding handles thermostats, see my post higher up with screenshots about heat/cool mode not working properly. Assume it’s linked to that

Now working for me after having made a dissociation of openhab from google home, a restart of my server, and a reassociation.

Thanks

1 Like

Hi,
Is it possible to control the thermostat mode without homekit? I use only Android mobile devices…
Thanks

Yes it´s possible.
You control it the same way with Android devices. Either by speak or by UI such as BasicUI or habpanel…

I’ve realized I have the same problem…

I have a question. I installed Openhab2 on my raspberry pi 3. That went OK.
I connected Openhab2 local to myopenhab by linking the secret key and uuid. That went ok.
I created a home.items file with to switches for my lights (Niko). That went OK.
I them connected Google Home to Openhab and my two switches showed up.
But when I try these switches I can turn them off and on but nothing happens with my lights.
Has someone an idea?

Regards,
Simon

From Saturday till now cloud connectivity with Google is down. There is some problems with servers?

Hello Marzima,

This this week my Google Home is finally speaking brazilian portuguese. But it´s not accepting openhab commands.

If I set it to english and say “Ok google, turn on cozinha light”, it executes the command and the kitchen light is turned on.

But if I set it to portuguese and say “Ok google, acender a luz da cozinha”, it says (in portuguese) that it can´t find the device.

Is it a Google issue, or can be something with OH?

Thats probably a Google issue. Make sure you got your items names (labels) right, or manually set the names in Google home for the devices. Otherweise Google will not recognize the items and will respond with the message, it cant find the device.
In doubt, post one of your items here. Without seeing your items, it´s almost impossible to help any future… If you believe you got your items right, then it´s a Google issue.
Notice - I´m NOT speaking about the tags. If your items works in english, you got the tags allright.

Hi Kim,

here are my items:

Switch Cozinha_Teto    "Cozinha: teto"  ["Lighting"]  {modbus="IOR11:09"}
Switch Cozinha_Pia     "Cozinha: pia"   ["Lighting"]  {modbus="IOR13:14"}

In Google Home I’ve created a room named “Cozinha” and added these two items to this room.
And I’ve also manually set their names in Google Home. First one to “Principal” and second one to “Pia”.

When google home is set to english I can turn on/off both lights saying “Turn on/off cozinha light”.

I think this might be a Google Home issue.

I´m pretty sure it is…
To turn on the first item (assuming you did not create a manual name in Google Home):
“Hey Google, turn on Cozinha: teto” Ofcouse that would have to be said in Brazilian or whatever langauge you use.

If you have created names manually in Google Home, you say, “Hey Google, turn on (whatever name you created)”.

If you believe its a Google Issue, you can test it pretty easy.
Change the name (in Google Home) for one of your items, to something you know for sure Google understand in the Brazilian langauge, no matter if it makes any sense or not. This is just to test it with.
If Google acknowledge the name, I´m sure it will work and you can turn on/off just fine… Then you know it´s the “Cozinha” or the room name which is given problems, and a Google issue.

One thing though… I noticed you have a : in the label of your item… I´m not sure if this could be a problem. Perhaps it´s worth a try without… Though, it shouldn´t have any influence, when you use manually created names in Google Home. But give it a try anyway…

Thats what I could think of. Hopefully something helps, otherweise, blame it on Google. We had the same situation in Denmark the first week after the danish language was released. Things worked on/off several days. But it has gotten alot better since.

You ever resolve this? I have a few lighting items in my Google Home app labeled as “Color” only. These seem to tie to working Hue bulbs, and switching these items do turn on specific Hue bulbs. The thing is, I have these bulbs defined elsewhere as other names, and they work fine there. I never had bulbs named with just “Color” before, so I’m not sure where they came from.

Currently I’m just ignoring them, and have not assigned them to a room, but would like to figure out what’s causing this, and remove them.