Official Google Assistant Integration for openHAB

Tags: #<Tag:0x00007f74613215e0> #<Tag:0x00007f74613214c8> #<Tag:0x00007f7461321270>

Problem seem to be gone now… Guess it was Google acting up somehow.
Still wish there was a way to troubble-shoot issues like this.

Hello @Kim_Andersen

changes in OHC were only around Notifications as @digitaldan mentioned.
Your issue was really complex and I keep in mind that the oh-google-assistant cloud function is the right place around „logic changes“.
BUT: If there is any tagging problem or config error this my lead you into many debugging sessions. So I would always verify that all items are setup, Unlink OH in GA app and last resport might be OHC.

Sometimes there are also timeouts with the Sync between GA and OHC. So relinking helps often.

There is a way to trouble shoot this, as we e.g. can check the logs about your items.

I know… I was rather frustrated, cause the only announced change was the one Dan announced. And at the very same time, I ran into this very complex issue…

Ohh… I know… I have probably been through all of them :grinning:

I did check, and doubble checked, well even tripple checked my tagging and items… Thats what worried me. There was no mistake… I have done these items and tagging so many times now, that I would state, I can do it with a blindfold :slight_smile: Ofcouse I can make mistakes like everybody else. And I did made one typo mistake. But since I always test every time I have done a change to a single item involving GA tagging, I´m beeing “punished” a few seconds after I made the mistake, (my typo mistake removed all my tagged items from the Google Home app as soon as I syncronised my devices, which I also do after changing an item)… So I always will know for sure, if the problem is at my end.

The problem with this GA connection is, that we´re not in control all the way. I cant see anywhere, if Google is messing around with something and creating an issue. I´m just a user beeing affected by their doings, without knowing.

The issue yesterday was very complex, cause it happened only after making a change to an item file having items with GA taggs. And because of that, and because we´re not in control all the way, I believe it was fair to conclude, that the problem would be at openhab level, or somewhere between openhab and Google. (I jumped to the wrong conclusion of the update Dan announced, because I cant see whats going on elsewhere).
I´m not aware of any option to log my items for this issue. Is that a logging feature at my end, or at the cloud end?

Hi @MARZIMA ,
Is there a way in the oh-google-assistant cloud function to detect errors in the tags presented and send a notification back to the to myOpenhab as a notification? or to the users email address, which has been used to link the Google Assistant?

It seems that this is the main, and only real issue?, we see with the OH-Google assistant services is users with tagging issues…

Or…perhaps someone with skills ( i dont ) could create a check script/binding to advise if the Tagging is bad… OH3 perhaps could have this built in?

Hi All,

Is there a way to send command FROM openhab to Google Assistant? Wanted to trigger a google home device by action from openhab-connected device…

See OrangeAssist - Google Assistant Integration.

I started to have issues around the same time and didn’t make any changes to my openhab config. I also can’t get it working any more. I removed the openhab link in Google home config and re-added. After the oAuth confirmartion it tells me that’s successful but somehow the process fails and I can’t get it reconnected any more

Have you tried restart openhab? Perhaps even clear the cache and tmp and then restart openhab?

Anyone knows anything about the smart blinds/ rollershutter integration on google assistant?

Can we implement this on OH? @MARZIMA?

There is already an issue on GitHub and a PR that adds shutter support to the google assistants addon.
See here: https://github.com/openhab/openhab-google-assistant/issues/59
I think then next step is for the maintainer , @marzima in this case, to do a final test and deploy it into the OH skill (cloud functions).
Massi

Since a few days my Google Home doesn’t answer any more with a feedback when I activate an item tagged as a scene.
Google has always said: “Okay, the scene xxx will be activated.” (or something similar).
Lights are not affected, they still work. It only affects the scenes. Does anyone else have this problem?

Its a new “feature” for routines:

Okay, it’s actually not a bug, it’s a feature. :slight_smile:

Probably it is not currently possible with Openhab for Google Home to respond with feedback, Google will simply be silent?

For some reason Google Home say device twice.
“Turn on Pump”
“Ok turning on Pool Pump Pool Pump”
Does someone know how to get rid of this?

Did you set a Nickname in Google Assistant? Also, check the value if your Item label.

No nickname and the label is correct.

What is the name of the room that you put this device in?

Pool

Is it possible to reactivate the verbal confirmations in openHAB?

In principle no. The only thing I can think of, is to set up your Google Home as chromecast devices and make a rule related to each item with in that rule something like:

say("OK, turning of ...", "voiceID", "deviceID")