Official Google Assistant Integration for openHAB

Thank you so much Bartus!
That worked! wrong double quotes where due to remote access to the file on windows system through teamviewer on an iphone…

Excellent! You definitely have to be careful with what tags you use (for now, you can only use Lighting or Switchable).

Also, after you’re done adding/modifying/tagging your items, just say “Hey Google, sync my devices” and that will make Google bring over any changes you make, you do NOT have to unlink/relink anymore.

After you’re done connecting everything, check out my post on scenes/routines, to make Google change all your lights with just one command :wink: 3 different methods to use scenes with Google Home & openHAB

Will do! thank you again!

Also experienced the “Couldn’t update the setting. Check your connection” bug on initially connecting. For me, I ended up adding labels and groups to each .items entries, which I hadn’t populated before, and that allowed the initial connection from Google Assistant to OpenHAB to work (I suspect it was the labels, but I didn’t check each independently). Just posting in case someone else is troubleshooting.


unfortunately still no update - I found that some have mentioned invalid tags. Should REST API Tagging work with the google assistant integration or only “items” file?

Can somebody maybe post a working item (ideally rollershutter “Lighting” ;)) that I can verify, what’s going wrong for me?


i got no example from my config, but REST API works well for google integration. You don’t have to set the tags in files

Thanks for the info…
is there any way to log what google is doing? Because everytime I want to start an action like “switch on kitchen blinds” google tells me to name the item.

All items are correctly shown in the google home app…

You can click on the menu bar in your Google Home app, and select “My Activity” - that will have a list of all commands you gave to google, and how it interpreted them.

I know I had issues with things sounds too similar to native GHome keywords. For example, when I said “Hey Google, turn on Wake Up” (one of my scenes), it kept recognizing that as me trying to set an alarm. I ended up changing the scene/item’s name to “Morning”.


unfortunately google understood exactly what it was supposed to “switch on kitchen blinds”, but still responded “I have to know which device should be used. Please repeat the command naming the device”

[I had to translate to english so the actual english log will probably look differently]

Are the blinds a Dimmer item? You might have to try saying something like:

“Set Kitchen Blinds to 50%” – it’ll probably respond “Setting Kitchen Blinds volume to 50%”, but it’ll work :wink:

They are all set as “Lighting” - works like a charm with Alexa and openHab App…but google is weird :wink:

I am running my own self-hosted OpenHAB Cloud instance. Is there any way to get the OpenHAB Google Home action working with my own OpenHAB Cloud instance instead of

Only if you negotiate with Google to add your server as a trusted service and set up OAuth2 authentication between the two. So for all practical purposes the answer is “no”.

You have to follow this guide:
Works perfect for me!

@rlkoshak and @rockster

Oooff. That’s a bit much for me at the moment. Thanks for the replies!

Oh yes, I forgot that you can set up the Oauth yourself. I’m actually doing stuff like that with my AIY Voice project. Thanks for reminding me. :slight_smile:


I added openhab2 to my google home and it discovered all the devices. I then assigned rooms. I have now since added an additional device to openhab2. How do I get it to show up on my google home? The only way I’ve been able to do it is unlink and relink openhab2 to google home which forces me to reassign all rooms.


Simply say “Hey Google, Sync Devices”

Great, thanks! Such a simple answer.


I had been using the Openhab and Google Home integration without issue for some time, but over the weekend I added some new devices and wanted to sync with Google Home.

I tried ‘sync my devices’ and an error was returned. So I tried to remove my account and re-add - big mistake!

I’m now unable to link openHab to my Google Home, I continually get the following error message: “Couldn’t update the setting. Check your connection”. (So now I have no devices linked to Google Home!)

I’ve reported the issue to Google Support and they are investigating, but I wanted to check if anyone else was having the same issue - I guess it is an issue on Google end and there is no workaround possible?