Official Google Assistant Integration for openHAB

myopenhab
openhabcloud
googleassistant
Tags: #<Tag:0x00007f0146a2c5f8> #<Tag:0x00007f0146a2c4b8> #<Tag:0x00007f0146a2c378>

(Gaël Grasset) #21

Awesome!!! Thanks again for your dedication and hard work!!!


(Ian Bishop) #22

Did a google home support chat and tried everything they had for me. No luck. We"

  • did a factory reset of my home
  • cleared the browser cache
  • tried linking from google assistant instead of the home app
  • deleted the authorizations in myopenhab.org (they seem to just stack up)

Any other ideas? Does anyone have the ability to watch the logs on myopenhab to see if there’s a clue there?


(Ian Bishop) #23

Recreated my myopenhab cloud account, that didn’t work either. Very odd.


(Aart) #24

Same issue here…


(Matthew Wedeking) #25

You can only use those 2 tags. Remove any other tags such as CurrentTemperature, CurrentHumidity, or Thermostat.


(AE) #26

awesome news, thank for all the hard work, i’ve been monitoring this thread daily and now all my 8 lights are all working great through google home!!

Couple things just to add here about my experience:

  1. Tagging the items. All my items were added through PaperUI which does not yet appear to support tagging. As per a post in another thread, I used the rest API to add the tags which went smoothly. Sample rest call:

curl -X PUT --header “Content-Type: application/json” --header “Accept: application/json” “http://localhost:8080/rest/items/[itemname]/tags/Lighting

I also just noticed you can add tags using the console:

openhab> items
Usage: smarthome:items addTag - adds a tag to the given item
Usage: smarthome:items rmTag - removes a tag from the given item

  1. I had similar issues with others where google said it couldn’t sync the devices. I re-linked openhab through the home app and then everything started working correctly. Not sure if it was since the first time I did not have any items tagged yet… either way, working fine now.

  2. just a general comment, I was a little surprised I did not have to expose the items to myopenhab through the configure openhab cloud services in paperui for them to show up in google home. I assume this was intentional given we have to tag them.


(cporourke) #27

Fixed my issue. Apparently, just adding tags to the .items file wasn’t propagating throughout openhab. I attempted to add tags using both Habmin and the REST API and found that I was getting an ‘http error 404 not found’. So I did the following:

  1. Stop the openhab2 service
sudo systemctl stop openhab2.service
  1. Navigate to the jsondb items files (located at /var/lib/openhab2/jsondb)
  2. Add the tags there and save the file.
  3. Start the openhab2 service
sudo systemctl start openhab2.service
  1. Added the openhab “device” through the Google Home App

This time the account linked and my items showed up under openhab.

My wife is asleep and I currently only have the lights in our bedroom added in openhab so no chance I’ll be testing them tonight, but I am confident that this has fixed my issue. Thanks for all of your help. It seems that most of these issues are related to tag issues in one way or another.


(Adtwomey) #28

Thanks for your work @MARZIMA it’s been stressful for you. Thanks for putting so much work into it.


(Mario Preis) #29

Awesome, great work.

What about roller shutters? I have a few Fibaro Roller Shutter 2 (ZWave). Can I control them via Switchable tags or will I be able to do that in the future?


(Florian) #30

Works! :upside_down_face:


(Alexander Elsing) #31

Excellent - what a milestone. Congratulations for getting this set up and getting it approved @MARZIMA and all contributors.

Looking forward to all the possibilities with this.


(Lolodomo) #32

What a great day after 6 months of waiting.
I just did a quick test before leaving my home and it seems to work very well. Just great.

For information, it is working with French too and probably with all languages supported by Google Home.


(Kuba Wolanin) #33

@MARZIMA thank you so much for all the work and dedication to this project!
I can only imagine how stressful this must have been for you! Kudos, man! :confetti_ball:

I am not able to connect my openHAB instance to myopenhab though (as I’ve described here and here), so I won’t be able to test with the integration right now.
I will try to set up a fresh openHAB installation on a separate RPi and hopefully I’ll see it on myopenhab some day :wink:

All the best!


(Dan Mize) #34

I was having trouble where it would tell me the accounts were linked and then just stop. If I went back in it looked like the accounts hadn’t been linked and I could try it again. I did this a few times to no avail.

Then I saw where in myopenhab I had about 10 links to google assistant voice control, so I deleted all of those authorizations and tried again and it all works! Maybe this will help someone else that is struggling. Now I can control my zwave lights!!! Thank you so much for your hard work!


(Martin Engelhard) #35

I had this error message too.
The reason was an item with an other tag than [“Lighting”] or[“Switchable”].

I found this item within the console after listing all items.


(scott dee) #37

Thanks, I’ll give that a shot. I know i have additional tags that work with Alexa


(Renan Muniz) #38

Try to remove all the tags and save the .items file, after add the “Switchable” and “Lighting” to your respective items and save .items file again and reboot your openhab server.
Once you’ve done that, just try adding it back in the google app.
This worked to me, I hope it’s useful.


(Ahiel) #39

Why does we remove all tags?
I’m using the tags for other addons…

The integration must support multiple tags!


(Renan Muniz) #40

I dont know why, but I think that is necessary to link the OpenHab device.


(mick) #41

I’m having the exact same issue. It all appears to link and then “Something went wrong, try again”. Let me know if you find anything before I do! :smiley: