OH 3.1 update UI Dashboard not loading

Hi,

yesterday I did an update sudo apt-get update and sudo apt-get upgrade on my RPI4 with openhabian. With that OH 3.1.0-1 was installed.

After that the webui is not reachable anymore. I’ve checked config and also service status. Service is running and config seems fine, but I can’t access the webui via defined ports 8080 or 8443. Even on localhost it is not working.

But the OH frontail log via Port 9001 is available.

Unfortunately I don’t see any logs. I don’t know what else to check to get the UI running again.

Any recommendation?

Thanks.
Regards
becksen

Hi @becksen, is the openHAB service running with no errors?

sudo systemctl status openhab

If it is not, then it might have an error at the bottom of that command, you’ll find more detail about it using the command:

sudo journalctl -u openhab -b

Are the log files themselves populated? Use the command:

openhab-cli showlogs

Hi Benjy,

thanks for the hints. I’ve excuted all in the mentioned sequence. But I don’t see an error :frowning:

[17:03:42] openhabian@openhab:~$ sudo systemctl status openhab
● openhab.service - openHAB instance, reachable at http://openhab:8080
   Loaded: loaded (/usr/lib/systemd/system/openhab.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/openhab.service.d
           └─override.conf
   Active: active (running) since Mon 2021-06-28 17:02:03 CEST; 1min 56s ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
 Main PID: 22009 (java)
    Tasks: 29 (limit: 4915)
   CGroup: /system.slice/openhab.service
           └─22009 /usr/bin/java -XX:-UsePerfData -Dopenhab.home=/usr/share/openhab -Dopenhab.conf=/etc/openhab -Dopenhab.runtime=/usr/share/openhab/runtime -Dopenhab.userdata=/var/lib/o

Jun 28 17:02:03 openhab systemd[1]: Started openHAB instance, reachable at http://openhab:8080.
Jun 28 16:54:41 openhab systemd[1]: Stopped openHAB instance, reachable at http://openhab:8080.
Jun 28 17:02:03 openhab systemd[1]: Started openHAB instance, reachable at http://openhab:8080.
[17:06:11] openhabian@openhab:~$ openhab-cli showlogs

==> /var/log/openhab/audit.log <==

==> /var/log/openhab/events.log <==

==> /var/log/openhab/openhab.log <==

Regards,
becksen

It’s unusual that there’s no attempt at installing anything… I’m assuming you can’t connect to the console? (openhab-cli console).

How do you usually set up your bindings? Is /etc/openhab/services/addons.cfg empty?

Yes openhab-cli console fails:

[23:30:29] openhabian@openhab:~$ openhab-cli console

Logging in as openhab
Failed to get the session.

Can’t remember I’ve ever changed it manually.

# The installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Note: If you want to specify your add-ons yourself through entries below, set the package to "minimal"
# as otherwise your definition might be in conflict with what the installation package defines.
#
# Valid options:
#   - standard : Standard setup for normal use of openHAB
#   - minimal  : Installation of core components, but no UIs or other add-ons. Use this for special headless setups.
#
# See https://www.openhab.org/docs/configuration/packages.html for a detailed explanation of these packages.
#
package = standard

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons. (default is $#
#remote = true

# A comma-separated list of automation services to install (e.g. "automation = groovyscripting")
#automation =

# A comma-separated list of bindings to install (e.g. "binding = knx,sonos,zwave")
#binding =

# A comma-separated list of miscellaneous services to install (e.g. "misc = openhabcloud")
#misc =

# A comma-separated list of persistence services to install (e.g. "persistence = jpa,rrd4j")
#persistence =

# A comma-separated list of transformation services to install (e.g. "transformation = jsonpath,map")
#transformation =

# A comma-separated list of UIs to install (e.g. "ui = basic,habpanel")
#ui =

# A comma-separated list of voice services to install (e.g. "voice = googletts,marytts")
#voice =

You’re not the only one with this problem. I upgraded 2 instances today and one works perfect and the other won’t start. Same results from those three commands. Any more wisdom from those that might know something or have suggestion on what to try?

Ira

I have the same problem after the update. The logs looks okay. Connecting to console is also possible.

Hi there - Had the exact same issue on Ubuntu, after upgrading OpenHAB 3.0 to 3.1.01.
There were absolutely no log entries to suggest an issue (syslog shows openhab starting message, and openhab.log was empty). It just didn’t seem to respond, even though the service was running (UI, Karaf console etc).

So I did manage to get it going however, although TBH, not sure which of the following steps resolved it:

  • Uninstalled openHAB via APT

  • Re-added the jfrog repository & key for OpenHAB APT install to work

  • Installed openHAB via APT

I had to repeat the above steps after stopping another (non-openhab) service using the openhab user, as the install process gave the following error:

Warning: openHAB's home directory is incorrect (/var/lib/openhab2)
but can't be changed because another process (623) is using it.

So I cannot be sure if the reinstall of OpenHAB iteself fixed my issue, or the same ‘user conflict’ (Where I am using the openhab user for another process) caused the original issue, and was the root-cause.

But none-the-less, other than a bunch of empheris exceptions in the log, OpenHAB is back on air and working…

1 Like

Hi, it works again for me.

I’ve taken the following steps:

@Ira and @finality thanks for confirmation the bold items are sufficient to fix the issue:

  • take backup: openhab-cli backup
  • Clean Cache: openhab-cli clean-cache
  • fix permissions via openhabian-config
  • change the brach from openHAB3 to main via openhabian-config
  • restart openhab service

Hope this solves your issues as well.

Regards
becksen

1 Like

Clean Cache and fix permissions fixed my problem. Thanks for help!

2 Likes

Clean cache and fix permissions worked here too. Thanks so much.

Ira

1 Like