OH 4 Z-Wave Bindings some items not working

Dear Community,

After a successful upgrade von OH2.5 to OH3 a couple of years ago, I’m struggling to upgrade from 3.1.0 to OH 4.0.4.

I’m running OH on Docker running on a synology DS718+ running DSM 6.2.4.
I’m using the Aeotec Z-Stuck Gen5 to connect to my Z-Wave devices. (Plugs, Thermostats, and windows sensors)

The start-up of OH4 went smoothly and I can’t recognise any error message in the log (See
Openhab4.txt (17.8 KB) )

The Z-Wave things seems to be working correctly except one items for my “Eurotronic Funk-Thermostat Spirit Z-Wave Plus” : The temperature setup_point.
Changes on the basic UI interface won’t change the target temperature on the device and changes on the devices won’t show on the UI.
Strangely enough, Actual temperature, Valve position, Mode, Battery level would work correctly.
I could not find any other problems with the others devices (plugs and windows sensors)

My items file looks like this

Number Temp_Target_Chambre "Consigne Chambre [%.1f °C]" <Temperature> {channel="zwave:device:0xc3c3dcf5:node4:thermostat_setpoint_heating"}
Dimmer Valve_Th_Chambre "Valve Th-Chambre" <Temperature> {channel="zwave:device:0xc3c3dcf5:node4:switch_dimmer"}
Number Temp_Chambre "T Chambre [%.1f °C]" <Temperature> {channel="zwave:device:0xc3c3dcf5:node4:sensor_temperature"}
Number Bat_Th_Chambre "Batterie Chambre" <batterylevel> {channel="zwave:device:0xc3c3dcf5:node4:battery-level"}

Only the first line is not working….

I’ve tried without success
1. Reinstall the binding
2. Reboot the system

I found following solution
• Start with a fresh openhab 4, and then
○ install the binding,
○ add the thing “Z-Wave Controller”,
○ add the thing “Thermostat”
○ Add the Items “Setpoint_heating” via the UI

As I got quite some devices to go through, I would prefer finding a way to change the item directly.

Number Temp_Target_Chambre "Consigne Chambre [%.1f °C]" <Temperature> {channel="zwave:device:0xc3c3dcf5:node4:thermostat_setpoint_heating"}

Any idea, what I need to change?

Many thanks for your support!

1 Like


I have a slightly different setup, but get the same odd behaviour after upgrade to OH 4.

I am just at the beginning of the debugging procedure, so if you get any hints, please tell me…


Not much into text configuration and do not have the device, but noticed there are two setpoint channels (which seems odd), but maybe the other one will work?

     <channel id="thermostat_setpoint_heating" typeId="thermostat_setpoint">
        <label>Setpoint (heat)</label>
          <property name="binding:*:QuantityType">COMMAND_CLASS_THERMOSTAT_SETPOINT;type=HEATING</property>
      <channel id="thermostat_setpoint_heating_econ" typeId="thermostat_setpoint">
        <label>Setpoint (energy heat)</label>
          <property name="binding:*:QuantityType">COMMAND_CLASS_THERMOSTAT_SETPOINT;type=HEATING_ECON</property>

Edit: also a Zwave debug while trying to set a temperature might provide clues.

Thanks for your answers.

The “normal” set point and the “eco” set point are actually here to set-up 2 temperature (like day and night for instance" and change from one to the other easily. I was not using it till now.

I’ve give a try to the _econ set point, but it does not help.

I don’t really know how to set-up the Z-wave log. Any hints you could share?

Apparently I will have to bind manually all my devices… Annoying!

From the UI; either on the zwave binding page (little wheel/gear thing) or from the settings, addon column, zwave. It has moved around recently and I do not recall where it is on OH4.0.4.

  1. Excluding and Re-including the “Eurotronic Thermostata Spirit” Z-Wave device does not solve the problem.

  2. Setting the Debug Level from “info” to “debug” ( - btw on OH 4.0.4 this is done on the zwave binding page with the gear thing, as described above - ) showed me some interesting information when changing the temperature for thermostat_setpoint_heating from BasicUI:

2023-11-27 01:08:06.231 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 30: Command received zwave:device:e7814e8038:node30:thermostat_setpoint_heating --> 19 [DecimalType]
2023-11-27 01:08:06.232 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 30: Received commands datatype DecimalType couldn't be converted to channels datatype QuantityType
2023-11-27 01:08:06.232 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 30: Command for unknown channel zwave:device:e7814e8038:node30:thermostat_setpoint_heating with DecimalType

It seems to be a datatype conversation issue…still debuging :wink:

1 Like

Does the item show up (or is configured) as number:temperature?

1 Like

Hey ! Thanks for your quick reply.

I have just seen your post with the solution in another thread (Problem to set values on ZWave-Thermostats Danfoss LC 13 (Living connect) - #2 by apella12)
All credits go to you.

The item is/was defined as Number.
I will try with Number:Temperatur tomorrow and keep you informed.

Hello again,

it worked !
Defining the item as Number:Temperature is the solution.

BTW I had to restart openhab to make the changes effective.

Thanks a lot.
Oscar Lemmer

Thank you for your support. It works now and a reboot is necessary.