OH2.5 offline add-on install problem

OH 2.5.12 , Java 8, Windows host - which might be relevant.

I’ve an openHAB 2.5 installation (yes, still) happily running in a commercial setting, and want to add SNMP binding to talk to a replacement UPS.
I’m well aware of Bintray repository changes-
and had previously elected to download the addons kar bundles, so that ‘offline’ installation should take place.
All good so far.

However, attempting install of SNMP v2 binding gives openhab.log error

2021-11-24 20:47:13.902 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-snmp': Error:
	Error downloading wrap:file:/C:/openhab2/userdata/tmp/kar/openhab-addons-2.5.12/javax/activation/activation/1.1.1/activation-1.1.1.jar$Bundle-Name=Javax%20Activation&Bundle-SymbolicName=javax.activation.activation&Bundle-Version=1.1.1
	Error downloading wrap:file:/C:/openhab2/userdata/tmp/kar/openhab-addons-2.5.12/javax/activation/activation/1.1.1/activation-1.1.1.jar$Bundle-Name=Javax%20Activation&Bundle-SymbolicName=javax.activation.activation&Bundle-Version=1.1.1

Note the error is about javax activation-1.1.1.jar ,not snmp binding directly.
I guess it is a dependency, I know little of these things. Looks to be a MIME handling utility.

I checked in folder
and yep, the addons kar has been successfully unpacked and includes that file.

The bit worrying me is the
Error downloading wrap:file:/C:/openhab2/userdata ... etc
is that wrap: an ordinary thing here?
I ask because I saw a longer dump on the console includes
Caused by: java.net.MalformedURLException: unknown protocol: wrap

Can I work around this by installing the package? How would I do that, I’ve no idea! (bearing in mind Windows hosting)

Can’t make any progress with this.
Looks like “wrap” is normal enough, something to do with installing from non-OSGI jar,well over my head.

I’ve fiddled about trying to bundle:install from karaf console,both from the “official” local copy unpacked from kar in /userdata/tmp/kar/openhab-addons-2.5.12/javax/activation/activation/1.1.1/, and,in case that was corrupt, another copy downloaded from elsewhere. I’m sure this all I really need, but no luck.

So I tried the “online” way I was hoping to avoid, set remote=true in addons.config, and fix the org.ops4j.pax.url.mvn.repositories from jfrog to jcenter.
To my surprise, still error points to local file

Error downloading wrap:file:/C:/openhab2/userdata/tmp/kar/openhab-addons-2.5.12/javax/activation/activation/1.1.1/activation-1.1.1.jar

but I suppose that may be where it looks after actually downloading it. Or, I’ve messed something up about un-doing local sourcing.
I’m a bit stuck now.

Well, I never really got to the bottom of this.
I’ve and old Win7 laptop running OH2 as “development” system for tinkering. This one gave me the SNMP install issue.
I’ve a Win7 desktop running a “live” OH2 - I took a chance and (using PaperUI, with local KAR files) installed SNMP v2 - bingo, worked no fuss.

So the process fine, just something screwed upon my dev system - some accident of history, I suspect a previous install/uninstall or whatever.
Fresh build of OH2 from local files, and SNMP installs fine of course.

Soo all sorted, and now the adventure in SNMP usage may begin.