OH2 do not accept the MiHome token

Tags: #<Tag:0x00007fc1fc6791f0>

Hi there!
I using OH2 2.5.0 on Ubuntu machine. The version of Xiaomi Home is 5.6.52
Yesterday I get my order with Xiaomi things and I’m trying to connect the gateway v3 to the OH2.
So the problem is that I can’t extract the token with MiToolkit.1.6. I’m getting error.
So I tried to find to find it manually and in files of com.xiaomi.smarthome I found the token.
But the OH2 do not accept it. I converted it in HEX, but it is unacceptable also.
When I try to paste in Paper UI I’m getting error “Input should satisfy expression …”
Also I think the token which I found is too big. Something about 474 symbols and when I convert it in HEX their count rising.
Any ideas how to get real token?
It tried all from here , but no success.
Thanks!

Thank you very much! I found the token by the modified app, and I connect the gateway to OH2.
But now I have another problem. If I have understood the documentation of the binding #Xiaomi Mi IO Binding this gateway is not supported.

What about the mihome binding?

I made a new topic about that -here. The problem is that I can’t put the gateway in the developer mode.
Thank you for your help!