OH2 & Homematic: No "CONTROL_MODE" data from HM-TC-IT-WM-W-EU


I dont get any data from following thing-datapoint:

When i Telegram myself (all 5 min. for example) the text of the linked Item.state, i get null.
And when i format the output of the linked Item to “Actual Mode [%s]” i only get “-”.
But a short time, at the beginning of the actual project, it worked and i saw states like “MANU_MODE” and so on…but just for some hours.
Dont know when exectly it stopped working…but now some rules also dont work anymore.
Other datapoints of this thing work.

Perhaps somebody has a tipp for me?

Best regards

Can add you the messages from the log file?
BTW which version of openHAB 2 are you running? There was a problem regarding timeouts that was fixed some builds ago.

Hello Martin.

Sorry but i dont know which logs u mean and where i can find them. And i also dont know where i can see the actual version of OH.

I installed openhab2-online with apt-get on a Raspberry Pi 3 with the KODI OS (think its Jessie).

I do run OH2 beta5 Online version and have the same issue:
No data from homematic:HM-TC-IT-WM-W-EU:76bxxxxx:MExxxxx:2#CONTROL_MODE

Any news on this?

Can you create an issue in the Githup repo?

Issue #1669 created.

Hi Falk!

I am occuring the same issue. Can you post a link to your submitted issue on github? For the number given by you I can only find this https://github.com/openhab/openhab/pull/1669, which does not seem to be related.



I have the same issue, but with a HM-CC-RT-DN and I have started a topic about it, but never received a reply:

Strange … I have no explanation where the issue is gone …

I created (a new) one:

Btw: my workaround currently is to link the HM-TC-IT-WM-W-EU with HM-CC-RT-DN (Heizkörperthermostat) and get the CONTROL_MODE data from there.

I am new to this … and it shows. The issue #1669 is in the OH2 issue tracker. The new issue has been rejected since my problem is OH2 related. Here is the link to the original issue:

FYI: I removed the Mapping and changed the item type to string, as told by this post over on github: https://github.com/openhab/openhab2-addons/issues/1669#issuecomment-273052752

Since then, I am getting a steady “MANU-MODE” from the channel. I will report back if anything changes…


@janw: Thanks for pointing that out! For some strange reason I had the item declared as a Switch. I just changed it to String and it works now without problems!

Coming back on this issue but using a eTRV Homematic IP thing I applied String as well:

String WZ1_Heizung_Mode “WZ_Heizung 1 Betriebsart [MAP(HMIP-eTRV.map):%s]” <“heating-off”> (gWZHeat1,WZ1,gHeatMode) { channel=“homematic:HMIP-eTRV:574299e0:000393C98D11A0:1#CONTROL_MODE” }

However, the value “MANU_MODE” or “AUTO_MODE” is not being display or received. I do have the feeling the channel 1 is used to write and therefore switch the mode, but my attempts to use other channels in order to get the value failed.

So I wonder if somebody is able to give me a hand on this issue in answering the question, how the value can be received?