Oh2 - knx, alexa

Hi there,

I hope I’m not off topic with my questions. I have running an oh1 environment with knx (mdt IP-Gateway). It works fine!
Now I tried to run oh2 on a pi3. The installation was no problem and also the creation of items, sitemap … were no problem. I have some problem with the knx gateway. The configuration is right. It is working in tunnel mode. I read that someone had problems with this. So I changed back to oh1. I bougth amazon’s alexa and tried to connect it to oh1 without success.

Now my questions: Is there a date for the knx 2 binding and could it solve my knx problems and is there also a way to run alexa with oh1? What’s your recommendation?

All the best

there is no support for amazon echo and OH1 and there wont be any.
But you can take a look at HA-Bridge: Hue Emulation
You can use the REST-Interface of OH1 to change Item states with HA-Bridge.

Hi Kingkill85,

thank’s for reply.
I tried to compile my own and tried a compiled one. Unfortunately without success! :o(
I have some trouble to start it. It ends with a lot of errors!
I tried different java versions and several parameters like server and port.
Have you got further ideas?

All the best!

My errors: (can’t attached them - I#m too new!)

java.net.UnknownHostException: openhab: openhab: unknown error
at java.net.InetAddress.getLocalHost(InetAddress.java:1484)

2017-02-14 18:39:55.990 INFO 9368 — [pool-1-thread-1] com.armzilla.ha.upnp.UpnpListener : Starting UPNP Discovery Listener
2017-02-14 18:39:57.587 ERROR 9368 — [ main] o.a.coyote.http11.Http11NioProtocol : Failed to initialize end point associated with ProtocolHandler [“http-nio-8082”]

2017-02-14 18:39:57.616 ERROR 9368 — [ main] o.apache.catalina.core.StandardService : Failed to start connector [Connector[HTTP/1.1-8082]]

org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8082]]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
2017-02-14 18:39:57.964 INFO 9368 — [ main] o.apache.catalina.core.StandardService : Stopping service Tomcat
2017-02-14 18:39:58.162 WARN 9368 — [ main] o.a.catalina.util.LifecycleMBeanBase : Failed to unregister MBean with name [Tomcat:type=Connector,port=8082] during component destruction

2017-02-14 18:39:58.202 ERROR 9368 — [ main] o.s.boot.SpringApplication : Application startup failed

have you can also tried the compiled release ? HA-Bridge Release

Yes, with the same result. But now it is running. But don’t know why. I used the precompiled version with jre8. Now I have to generate the switches in the bridge.

Looks good! Thank’s a lot!

Hi again,

I tried to configure the bridge now. I get the following result when I type in the url :/api/devices:


But the alexa app can not find the test device. I also put an entry into the item file like this:
Switch kueche_spuele “Deckenlicht Spüle” (kueche,licht) { knx=“1/0/6” } hue=“1”

any ideas?

All the best