OH2 Synology Installation - port undeffined


I would like to install OpenHAB- on my synology.

I get an error:

“port undeffined configured for this package is either used by another service or reserved for system use. Please disable or modify the conflicting service, or contact the developer to modify the package configuration.”

I use DS1815+ with bunch of software on.

In the link below looks like it helps if I would uninstall Cloud Station, but I need it…

Is there any way to install OH2 without uninstalling existing packages.



looked for 8080 port in use but found none:

netstat -an | grep 8080

Found file /usr/local/etc/services.d/Zarafa.sc that had 8080 writen in config. I don’t have Zarafa installed anymore anyway.

Changed Zarafa port with vi / or could just deleted the file:

vi /usr/local/etc/services.d/Zarafa.sc


did anybody ever solve this? I also checked the ports, there is nothing on 8080, still get the error that 8080 is in use when I try to install openhab…spk to my synology.

I solved it by downloading the spk, using 7-Zip to open the package and editing the INFO - file. I changed the “adminport” and saved to the spk package.

Installation worked!