OH2 Z-Wave refactoring and testing... and SECURITY

security
zwave
Tags: #<Tag:0x00007f6ce44b8ba8> #<Tag:0x00007f6ce44b8978>

(Kevin) #2311

I’ve got about 20 devices, and wish I had about 60 :slight_smile: Most are contact and motion sensors for security purposess, only a few switches and outlets which are growing as I find the sales. Lol


(Scott Rushworth) #2312

A week ago, your secure inclusion probably would have failed then. Looks like your results are another case showing that the fix was successful!


(Dan) #2313

I have several dozen zwave devices, and am happy to report that secure inclusion of my Danalock v3 worked like clockwork.


(Kjetil Asdal) #2314

@chris,
I am sure you get a lot of questions on this, and I am sorry to add to the load. I was just wondering if you have any thouhgtsh on when the development version of the binding is ready to become the “official” version. I fully understand and accept that you are not working from a detailed project plan, but I guess you have a feeling for the maturity of the new version, and thus a view on when you think it is time to make the switch.

I did a search on the forum to see if you had answered this question somewhere. My apologies if I missed your answer in some other thread, and thanks for all you work on this binding!


(Chris Jackson) #2315

It is something I’ve been asked a couple of times recently, but often in unrelated threads, or this thread which is impossible to search :wink:

The plan is to try and tidy things up and fix a couple of issues over the coming few weeks and then to merge this into master. I have 2 or 3 specific things I want to address -:

  • Secure inclusion in large networks (seems done!)
  • Association issues
  • Handling of dead nodes (moving back to old system rather than using the failed check on the controller which seems to be unreliable).

(William Hawkins) #2316

Hi @chris I’ve been having some issues with my Trane thermostat after updating recently. I hadn’t updating in a while. I have the issues with the jar posted in the first link and with the one I compile myself to add some channels for the thermostat. The thermostat will respond to all the commands when sent, but never reports status back. Could this be related to the other association issues? I’ve been trying to troubleshoot it over the past week or so, but have had no luck. It appears that the binding sends the association set command from what I can tell. I have a zwave debug log from startup through trying to set the assocation, if that would help.

Thanks for all the work you do for this binding!


(Manny) #2317

Hello
Thanks Chris for your great work and thanks you all for your input and contribution. I am also thinking to implement/install door lock with my OH2 and I would like to get recommendation for a door lock. A lock that will be a good choice and easy to implement.
I contact a manufacturer in China and I can get from them a nice Z-wave Biometric Fingerprint Door Lock with nice interface for ~$150.
My question is : will it be possible to implement this lock, what I will need from them and how completed it will be?

Thanks
Manny


(Chris Jackson) #2318

Generally, I’d say yes as ZWave should ensure interoperability. However, without some information about the device, it’s hard to say much more than that…


(Brandon Miller) #2319

New install on Windows and I haven’t had any luck with Z-Wave. Seeing ksarauer’s screenshot made me look at my controller in “things” and I don’t have any of the same network settings.
It is an aeotec z-stick gen5 on OpenHAB 2.2 and using this new z-wave binding.
Here is what I see for settings.

zwave


(Chris Jackson) #2320

That would be quite strange - I suspect you are not showing the advanced options? If not, select advanced mode in the menu.


(Sergei Vardomatski) #2321

Hi @chris and all. Sorry if I re-ask what was asked earlier, however didn’t found in the thread.

  1. I have a POPP 012501 lock relay, Fibaro Roller Shutter 2 and Aeon Tech 5 stick on my network and nothing else. dev binding ver. Jan 5th.
  2. I successfully included POPP lock relay via Habmin UI with “use secrity for all devices” on (won’t do without that).

The relay works well when it is in direct connection with the stick. If I take it to the door and it can only communicate via Roller Shutter it behaves exactly as it did before security appeared: it blinks the led when I “open” it and it doesnt swithc the contact on.

Therefore seems like security stops working when node connects via mesh?

Here is how the network looks. 2 is lock. 7 is Roller Shutter

Screenshot_2


(Chris Jackson) #2322

I don’t know what that means?

I’m confident that security works within the mesh - it’s part of ZWave. This is not under the control of the binding at all. If you move the device around, then you probably should consider doing a heal so that the routes are updated otherwise the device will not be able to communicate back to the controller.


(Scott Rushworth) #2323

Is this device securely included? Among other things, the database doesn’t have the SECURITY CC listed, although Zwave Alliance does. The roller shutter device also looks to have issues in the database. I don’t know if this is the root of your problem, but should probably get cleaned up. +1 on doing a heal after moving it.

Here is my detached garage door opener, which is the furthest device from the controller (definitely out of range). It works great through the mesh.


(Lucas Christian) #2324

Hi all,

I’ve been beta-testing security with a few devices (actually none of them locks). I have a Fibaro motion sensor that includes with security just fine. I have security mode set to “All Devices”.

I’ve had less luck with my two Aeotec devices. For these you have to double-tap the set button to put them into a special “Secure Inclusion Mode”. After that, looking at the logs, the binding appears to attempt a security negotiation, then times out a few seconds later with “SECURITY Status=Failed”. I can’t seem to find any obvious errors before that.

Anyone else have luck with Aeotec devices? Anything I can do to help debug?

Thanks @chris for all your work on this.


(Scott Rushworth) #2325

Are the devices already included? In my experience, when a device times out that quickly during inclusion, I’ve forgotten to exclude it first. I think you will find something in the debug log about this. Which Aeotec devices are you having this trouble with?


(Chris Jackson) #2326

This won’t matter - the binding will stiill detect and use security if the device reports it is supported.

This definitely won’t matter…

+1 :wink:

Yes - I’ve used Aeotec sensors here - one of the Aeon multisensors was actually the main device I used for all the initial security development. There should be no issues with Aeon devices - or really anyone elses since all devices use the standard libraries from Sigma.


(Martin) #2327

I am now on OH2.2 with the test-version of the zwave binding.

I am having trouble with the Aeontec ZW100 Multisensor 6 in this configuration - which worked with OH2.1 before: I receive temp-updates etc - but no ON/OFF when motion triggers.

Making sure that association groups are set does not seem to make a difference.

The ZW100 in question has firmware 1.7.

Does anyone have a working setup with OH2.2, zwave-test-binding and the ZW100 ? Can you recognize the problems I mention and/or what firmware do you run on the sensor ?


(Scott Rushworth) #2328

Did you delete all of your Things after the upgrade to this version of the binding? I recently resolved an issue with a different device that was not reporting by deleting the Thing.


(Lucas Christian) #2329

@5iver They should definitely be excluded. Before attempting the secure inclusion I used Tools -> Exclude Devices in HABmin and they both went back to their rainbow LED patterns and HABmin confirmed they were excluded. Could attempting the inclusion too soon after exclusion be a factor?

The devices are an Aeotec Multisensor 6 ZW100 firmware v1.8, and a WallMote Quad ZW130 FW 1.8. My interface is a Linear HUSBZB-1.

Here’s a snippet of the logs: https://www.dropbox.com/s/hlnn5p2o4c3s3wv/selected_logs.log?dl=0
This was trying to include the WallMote (NODE 2), and was right after I also did a hard reset of the controller (and restarted the binding). There’s some early noise in that file about a “NODE 27”, I’m not sure what that is since the controller had just been reset.


(Chris Jackson) #2330

No - I don’t think you can do this fast enough to cause a problem.

All I can suggest is to try again. There’s nothing especially wrong in the logs - it looks like the device doesn’t respond to a message. It might be that the device went to sleep - the binding thinks it’s awake, but that doesn’t mean it is. You could try waking it up again during the initialisation although I would have expected it to stay awake for a reasonable period of time after inclusion.

I’ve certainly tested this on a ZW100 but not the wall mote.