OH3.2 KNX Binding tunneling log file warnings (disconnect, timeout , received L-data reqest)?

My config:
OH3.2 stable release , installed on a QNAP VM with Ubuntu20.04LTS and Zulu Java as per installation instructions. All configs (things, Items, sematic model) are done on a textual basis.


First of all the entire Locations, equipment properites work as expected. Functionally I do have no issue. I can switch on/of lights, blinds and see heating temperatures. However my log file is full of warnings I dont know what to do with it. I have experiement quite a bit with the knx bridge parameters with no sucess. After a wihle 5-10Min after reboot these errors start to pollute my log file. All KNX things show “online” btw.

Basically those 3 warnings appear (see log extract below)

  • response timeout waiting for confirmation
  • disconnected not gracefully (timeout)
  • received L-Data request … hop count 6 repeat, tpdu 81

Anybody any idea ? Many thanks
M

Extract of my current knx config:

Bridge knx:ip:bridge [
	type="TUNNEL",
    ipAddress="192.168.1.222",
    portNumber=3671,
    localIp="192.168.1.95"
] {
// 1.1.1 Lingg Jahnke eibDUO Schaltaktor 2x6f 16A 
    Thing device 1_1_1_Schaltaktor "LinggJanke Schaltaktor 1.1.1" [
        address="1.1.1",
        fetch=false,
        pingInterval=1500,
        readinterval=0
     ] {
        Type switch        : UG_Elektro_Deckenlicht             [ ga="0/1/1+<0/4/1" ]
        Type switch        : UG_Werkstatt_Deckenlicht           [ ga="0/1/2+<0/4/2" ]
        Type switch        : UG_Hobbyraum_Deckenlicht           [ ga="0/1/3+<0/4/3" ]    
        Type switch        : UG_Abstellraum_Deckenlicht         [ ga="0/1/4+<0/4/4" ]    
        Type switch        : UG_Flur_Deckenlicht                [ ga="0/1/5+<0/4/5" ]
        Type switch        : UG_Heizraum_Deckenlicht            [ ga="0/1/6+<0/4/6" ]    
    
    }
}

Log file is full of this "warnings"

2021-12-29 14:56:16.913 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - **response timeout waiting for confirmation**
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.1.254 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:269) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:261) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:213) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:423) ~[bundleFile:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:385) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:402) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:604) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.checkSendDisconnect(TransportLayerImpl.java:596) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.handleConnected(TransportLayerImpl.java:504) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl$NLListener.indication(TransportLayerImpl.java:131) ~[bundleFile:?]
	at tuwien.auto.calimero.link.AbstractLink$LinkNotifier.lambda$frameReceived$0(AbstractLink.java:193) ~[bundleFile:?]
	at tuwien.auto.calimero.internal.EventListeners.fire(EventListeners.java:137) [bundleFile:?]
	at tuwien.auto.calimero.link.EventNotifier.fire(EventNotifier.java:169) [bundleFile:?]
	at tuwien.auto.calimero.link.EventNotifier.run(EventNotifier.java:88) [bundleFile:?]
2021-12-29 14:56:16.915 [WARN ] [calimero.mgmt.TL 192.168.1.222:3671 ] - disconnected not gracefully (timeout)
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->1.1.254 L_Data.req, system priority hop count 6 repeat, tpdu 81
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:269) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:261) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:213) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:423) ~[bundleFile:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:385) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:402) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.sendDisconnect(TransportLayerImpl.java:604) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.checkSendDisconnect(TransportLayerImpl.java:596) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl.handleConnected(TransportLayerImpl.java:504) ~[bundleFile:?]
	at tuwien.auto.calimero.mgmt.TransportLayerImpl$NLListener.indication(TransportLayerImpl.java:131) ~[bundleFile:?]
	at tuwien.auto.calimero.link.AbstractLink$LinkNotifier.lambda$frameReceived$0(AbstractLink.java:193) ~[bundleFile:?]
	at tuwien.auto.calimero.internal.EventListeners.fire(EventListeners.java:137) [bundleFile:?]
	at tuwien.auto.calimero.link.EventNotifier.fire(EventNotifier.java:169) [bundleFile:?]
	at tuwien.auto.calimero.link.EventNotifier.run(EventNotifier.java:88) [bundleFile:?]
2021-12-29 14:57:49.752 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:57:52.754 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:57:55.756 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:57:58.757 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:01.759 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:04.765 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:07.767 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:10.769 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:13.770 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:16.772 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:19.774 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:22.775 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:25.777 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:28.780 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:31.782 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:34.783 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:37.785 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:40.787 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81

Hi Mario,
I am not using an address in the Thing config, only GAs:


Bridge knx:ip:bridge [
	type="TUNNEL",
	ipAddress="localhost",
	portNumber=3671,
	readingPause=50,
	responseTimeout=10,
	readRetriesLimit=3,
	autoReconnectPeriod=60,
	localSourceAddr="0.0.0"
] {
	Thing device wetterstation "Wetterstation" [
		pingInterval=300,
		readInterval=3600
	] {
		Type number : Wetterstation_Temperatur [ ga="9.001:<3/5/13" ]
		Type number : Wetterstation_Windgeschwindigkeit [ ga="9.001:<3/5/11" ]
		Type number : Wetterstation_Helligkeit [ ga="9.004:<3/5/10" ]
		Type switch : Wetterstation_Regen [ ga="<0/2/10" ]
	}
	Thing device lichter "KNX Lichter" [
		readInterval=3500
	] {

		Type switch : Licht_Zentral [ ga="0/1/0" ]
		Type switch : Licht_Zentral_Garten [ ga="0/1/1" ]
		Type switch : Licht_Zentral_DG [ ga="0/1/2" ]

The logfile is as it should.
Cheers
Marco

Hi Marco,

thanks for the suggestion. On first test I went minimalistic on the things config as you suggested.
This actually elliminiated the received L-Data request - ignore warnings :

2021-12-29 14:58:16.772 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:19.774 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81
2021-12-29 14:58:22.775 [WARN ] [Xnet/IP Tunneling 192.168.1.222:3671] - received L-Data request - ignore 1.1.254->15.15.12 L_Data.req, system priority hop count 6 repeat, tpdu 81

The “no confirmation reply” and “disconnected not gracefully (timeout)” continued to appear :frowning:
I finally gave it a try to operate in router mode and this actually works without any error using the broadcast ip where my Jung router listens to.

I think this is proably more a Calimero KNX Binding thing than a OpenHAB issue. It should actually work in TUNNEL mode too to my understanding.

Meanwhile I found a similar issue: knx IP issue so I guess we are not alone with this “problem”.

Hmm as for me I can run with Router mode but all my predessesor versions 1.7, 1.8,2.5 were running in TUNNEL model. I would like to understand the root cause here.

M

I have the same issue here. I upgraded to OH 3.2 some days ago and now my log is full of errors of that type

2022-01-16 17:45:25.698 [WARN ] [NXnet/IP Tunneling 192.168.0.45:3671] - response timeout waiting for confirmation
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->8/2/0 L_Data.req, low priority hop count 6 repeat, tpdu 00 00
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:269) ~[?:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:261) ~[?:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:213) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:423) ~[?:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:385) ~[?:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:402) ~[?:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.send(ProcessCommunicatorImpl.java:461) ~[?:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.readFromGroup(ProcessCommunicatorImpl.java:430) ~[?:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.read(ProcessCommunicatorImpl.java:352) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.readNextQueuedDatapoint(AbstractKNXClient.java:289) ~[?:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.lambda$1(AbstractKNXClient.java:200) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:834) [?:?]
2022-01-16 17:45:25.825 [INFO ] [b.core.model.script.knx.update.rules] - WPL17_Aussentemperatur updated - sending it to KNX: 2.7 °C
2022-01-16 17:45:28.713 [WARN ] [NXnet/IP Tunneling 192.168.0.45:3671] - response timeout waiting for confirmation
tuwien.auto.calimero.KNXTimeoutException: no confirmation reply received for 0.0.0->3/0/152 L_Data.req, low priority hop count 6 repeat, tpdu 00 80 10 0c
	at tuwien.auto.calimero.knxnetip.ClientConnection.doExtraBlockingModes(ClientConnection.java:269) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.ConnectionBase.send(ConnectionBase.java:261) ~[bundleFile:?]
	at tuwien.auto.calimero.knxnetip.KNXnetIPTunnel.send(KNXnetIPTunnel.java:213) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.onSend(KNXNetworkLinkIP.java:423) ~[bundleFile:?]
	at tuwien.auto.calimero.link.AbstractLink.send(AbstractLink.java:385) ~[bundleFile:?]
	at tuwien.auto.calimero.link.KNXNetworkLinkIP.sendRequestWait(KNXNetworkLinkIP.java:402) ~[bundleFile:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.send(ProcessCommunicatorImpl.java:461) ~[bundleFile:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.write(ProcessCommunicatorImpl.java:410) ~[bundleFile:?]
	at tuwien.auto.calimero.process.ProcessCommunicatorImpl.write(ProcessCommunicatorImpl.java:365) ~[bundleFile:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.sendToKNX(AbstractKNXClient.java:460) ~[bundleFile:?]
	at org.openhab.binding.knx.internal.client.AbstractKNXClient.writeToKNX(AbstractKNXClient.java:420) ~[bundleFile:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.lambda$7(DeviceThingHandler.java:253) ~[bundleFile:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.withKNXType(DeviceThingHandler.java:148) [bundleFile:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.withKNXType(DeviceThingHandler.java:142) [bundleFile:?]
	at org.openhab.binding.knx.internal.handler.DeviceThingHandler.handleCommand(DeviceThingHandler.java:248) [bundleFile:?]
	at jdk.internal.reflect.GeneratedMethodAccessor181.invoke(Unknown Source) ~[?:?]
	at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
	at java.lang.reflect.Method.invoke(Method.java:566) ~[?:?]
	at org.openhab.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:154) [bundleFile:?]
	at org.openhab.core.internal.common.InvocationHandlerSync.invoke(InvocationHandlerSync.java:59) [bundleFile:?]
	at com.sun.proxy.$Proxy2576.handleCommand(Unknown Source) [?:?]
	at org.openhab.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand(ProfileCallbackImpl.java:80) [bundleFile:?]
	at org.openhab.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem(SystemDefaultProfile.java:48) [bundleFile:?]
	at jdk.internal.reflect.GeneratedMethodAccessor292.invoke(Unknown Source) ~[?:?]
	at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
	at java.lang.reflect.Method.invoke(Method.java:566) ~[?:?]
	at org.openhab.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:154) [bundleFile:?]
	at org.openhab.core.internal.common.Invocation.call(Invocation.java:52) [bundleFile:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:264) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:834) [?:?]
2022-01-16 17:45:28.713 [WARN ] [nx.internal.client.AbstractKNXClient] - Value '4108' could not be sent to the KNX bus using datapoint 'command DP 3/0/152 'knx:ip:bridge', DPT 7.013, low priority': no confirmation reply received for 0.0.0->3/0/152 L_Data.req, low priority hop count 6 repeat, tpdu 00 80 10 0c. Giving up now.

As it has worked properly before with OH 3, I am assuming there was a minor change that is causing this issue. I am also using KNX configuration in the knx.things file, which has worked good.

Bridge knx:ip:bridge [ 
    ipAddress="knxgw.home", 
    portNumber=3671, 
    localIp="0.0.0.0", 
    type="TUNNEL", 
    readingPause=80, 
    responseTimeout=10, 
    readRetriesLimit=3, 
    autoReconnectPeriod=33,
    localSourceAddr="0.0.0"
] {
    Thing device generic [
        address="2.1.100",
        fetch=true,
        pingInterval=300,
        readInterval=3600
    ] { ....

For me it seems that not only OH not receives feedback, but that values send from OH to KNX not “arrive” at the KNX. My temperature (comes from heating to OH and is sent to KNX) is not beeing updated on KNX. But OH receives the values from KNX :flushed:

Has there been a code change in this part?

Hi,
i have i similiar issue with KNX Binding. My config is as folow:

openHAB 3.3.0 Build #2685

KNX Binding Version:3.3.0.SNAPSHOT

knxd on Raspberry with TPUART installed

Blockquote
Bridge knx:ip:RASPI-EIB [
type=“TUNNEL”,
ipAddress=“192.168.1.28”,
portNumber=3671,
localIp=“192.168.1.210”,
readingPause=50,
responseTimeout=20,
readRetriesLimit=5,
autoReconnectPeriod=60,
localSourceAddr=“0.0.0”
] {
Thing device TSM10B412_1 “Garage Schalter Tuer” @ “Garage” [ address=“1.1.58”, fetch=false, pingInterval=600, readInterval=0 ]
{
Type switch : Channel_10 “Garage Licht” [ ga=“1/1/0” ]
Type rollershutter : Channel_11 “Garage Tor” [ upDown=“2/1/0”, stopMove=“2/1/10”, position="" ]
}
Thing device TSM10B412_2 “HWR Schalter Garage” @ “HWR” [ address=“1.1.20”, fetch=false, pingInterval=600, readInterval=0 ]
{
Type switch : Channel_20 “HWR Licht” [ ga=“1/1/0” ]
Type rollershutter : Channel_21 “HWR Jalousie” [ upDown=“2/1/0”, stopMove=“2/1/10”, position="" ]
}
Thing device TSM10B412_3 “HWR Schalter Fenster” @ “HWR” [ address=“1.1.11”, fetch=false, pingInterval=600, readInterval=0 ]
{
Type rollershutter : Channel_30 “HWR Jalousie” [ upDown=“2/1/0”, stopMove=“2/1/10”, position="" ]
}
Thing device TSM10B412_4 “HWR Schalter Kueche” @ “HWR” [ address=“1.1.13”, fetch=false, pingInterval=600, readInterval=0 ]
{
Type switch : Channel_40 “HWR Licht” [ ga=“1/1/0” ]
Type rollershutter : Channel_41 “HWR Jalousie” [ upDown=“2/1/0”, stopMove=“2/1/10”, position="" ]
}
Thing device TSM10B412_5 “Kueche Raumtemperatur” @ “Kueche” [ address=“1.1.47”, fetch=false, pingInterval=600, readInterval=0 ]
{
Type switch : Channel_510 “Kueche Licht” [ ga=“1/1/1” ]
Type rollershutter : Channel_511 “Kueche Jalousie” [ upDown=“2/1/1”, stopMove=“2/1/11”, position="" ]
Type number : Kueche_Temperatur “Temperatur EG Kueche” [ ga=“9.001:<3/3/1” ]

For a time after restart all is good but after a day or may two, they are no connection possible without restart of OpenHab. The Binding showa online but it is not online!

If i try to switch light, nothing happens! With ETS 5.0 and Groupmonitor is switching possible
and in knxtool vbusmonitor i can see all from ETS but nothing from Openhab.

In Logtail i see this, when i try to switch something.

Is there a bug in KNX Binding with TPUART?

Glad I am not alone with that “issue” . Even if this does not help :slight_smile: .

Before OH3 with OH2.5 I did not had this problems. As said, using the Router mode and going minimalistic with the .thing confiuration worked for OH3.2 but I still would like to understand the rootcause and whats needed to fix it. But I do have no ideas how to debug it further.

M

Hello,

after testing to find the problem, i observe the following:

  • after one day the responding of KNX binding dont work in both directions
  • i can only switch off light with OH GUI but no more switch on
  • i can switch with KNX ETS on and off without problems
  • after i “pause” the switch in OH GUI and “resume”, i can switch off and on light
  • the command to switch on light, isn`t shown in logtail, when the malfunction exist. Only the switch off command ist shown in logtail
  • after i restart the switch in OH GUI, all commands shown in logtail.

gpowa