[OH3] Addons-Section empty in UI, not possible to install bindings

Hello community,

I am facing a strange issue, I wanted to install a new binding (modbus) and just realized that my Addons-Section in the menu is completely gone:

I tried in different browsers, different clients, empty cache etc. but still empty. Also reboot did not help.

If I go the way via things (Things, New, install more bindings) I get “No addons available”.

Any idea where I can start searching what is wrong?

There is a setting under Settings for Addon-Management.

Choose whether to download add-ons when they are installed or use a locally stored collection of all the add-ons.
I am not sure if such happens if the Access Remote Repository is switched to off with no addons stored locally.

Where do I find this setting?

What I tried in the meantime, I edited the file “addons.config” found unter userdata/config/org/openhab and added modbus:


But this did neither install modbus nor bring back the addon-settings in UI.

MainUI Settings, second Column System Settings

Hmm, are you sure we talk about OH3? There is no such setting in OH3.

But I found out something else, I started my backup-Pi which runs a backup about two weeks old, on this Pi the missing section is available. The Menu entry “addon management” on the right is also missing on the production Pi.

At least I know I have a working backup I could use, but it would be cool to know what went wrong…

I think there is already an issue opened for this.

Yes I found it:

“Symptoms” are like in my case, I also did not touch Openhab itself since last backup on 18th where it is still working.

BTW cleaning the cache helped, now I can see addons-section again.

1 Like

Thank you! I had the same problem and cleaning the cache works for me too.