[OH3] Bindings & Things disapeared


I am currently experimenting OpenHAB 3.0 but I am facing an expected problem. I use Docker on a Synology NAS. I migrated successfully from OpenHAB 2.5 to OpenHAB 3.0. Everything ran fine at the end. But it is not yet in production (OpenHAB 2.5.1 is still the version managing my home). However, very recently, all my bindings in 3.0 as well as the Things completely disapeared. However, Items are still listed. I do not know why I got this… I did not update the container.

I tried to re-install the bindings, but I cannot. In the log file, I have this message

2021-01-27 12:14:43.895 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-networkupstools, openhab-persistence-mapdb, openhab-binding-exec, openhab-binding-deconz, openhab-misc-openhabcloud, openhab-binding-network, openhab-transformation-regex, openhab-ui-habpanel, openhab-transformation-jsonpath, openhab-binding-zwave, openhab-binding-zigbee, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-ntp, openhab-misc-homekit, openhab-binding-openweathermap, openhab-binding-astro, openhab-binding-freebox, openhab-transformation-scale, openhab-binding-samsungtv': Error:
	Error downloading mvn:org.openhab.addons.bundles/org.openhab.binding.zwave/3.0.1

Do you have any idea about this problem ? Am I the only one facing this problem ?

Best regards,


It looks like you are using 3.0.1 that is currently being released, however, as Kai has mentioned there was a problem with the build.

Binding and things disapeared when using 3.0. It works fine for a couple of weeks and suddently Binding and Things disapeared when I started again the container.

I just updated to 3.0.1 today. I will go back to 3.0.0 to see if I have the same problem reinstalling the binding.

Thanks for the help,


I went back to 3.0.0 and I was able to reinstall the bindings. However, no way to get back the things… I will have probably to do it manually…


Nope, I have the same problem. Back on 3.0.0 everything’s fine. Let’s wait until this is sorted out. Here’s Kais statement regarding the failed build.

You could see if you have a backup in the ‘userdata/jsondb/backup’ directory (maybe a different location depending on how you installed / configured).

The backup filenames are like ‘1611072556703–org.openhab.core.thing.Thing.json’ and to restore it, stop openhab, copy the file to ‘userdata/jsondb’ as ‘org.openhab.core.thing.Thing.json’ and restart openhab.

Problem fully solved. File ‘org.openhab.core.thing.Thing.json’ was empty… I used the version in the backup directory. Thanks for advice.