OH3: How to install latest Zwave binding snapshot?


Newb to OH, Linux and modern scripting in general - the last time I “programmed” anything was back in the Commodore days. :slight_smile:

The good:
After a lot of poking around and reading, I managed to successfully install OH 3.0.1 on a PI4B Rev 1.2 using Raspbian 10 (Kernel 5.10.17-v71+) and an Aeotec Z-Stick Gen5+. I’ve also managed to add plenty of devices, set up rules/schedules, integrate it with Alexa etc…

The not-so-good:
I am attempting to update the Z-wave binding (to latest snapshot), but am having no such luck. I’ve exhausted my Google-fu skills, cruised the forum and documentation, followed several old threads and even attempted to utilize a script (zzManualInstaller.sh). The challenge with many of these is that most speak to earlier versions of OH, paths or documentation that no longer exist for 3.X, or were written well above a newb’s level of understanding (assumes a certain familiarity with previous pathing/versions of OH/tinkering etc.).

I have obtained and placed the latest stable snapshot (org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar) in /usr/share/openhab/addons and rebooted. I’ve even tried uninstalling the existing z-wave binding prior to placing the snapshot in addons and rebooting.

Karaf shows the new binding installed, but not active.

“251 ? Installed ? 80 ? ? openHAB Add-ons :: Bundles :: ZWave Binding”

If I attempt to start the bundle I receive the following error message:

“Error starting bundle 251: Could not resolve module: org.openhab.binding.zwave [251] Unresolved requirement: Import-Package: org.osgi.framework; version=”[1.9.0,2.0.0)"

From the above, I can recognize that it’s missing something, but I have no idea where to find (or how to install) said something. I’m sure this is a piece of cake for many, and as obvious as the nose on one’s face, but I’m still green, and even that’s an understatement. If anyone could provide a compass heading, I’d greatly appreciate it.

If you require logs, please share how I can locate and provide them (sadly, I am THAT green).

Thanks in advance!


FWIW i’ve had the same issue with the latest CI build of the z-wave binding but only since yesterday. Previously I was installing CI builds without issue. I install via the Karaf console rather than /addons and had the issue with the 9th April build rather than the 7th but got the same error as you when trying to start the bundle.

Sadly I moved to OH 3.1.0 M3 at the same time and seem unable to roll back, so can’t tell whether the problem is with the binding or the milestone release of OH, or both.

Long way of saying - I think you’re doing the right things but something has changed with the binding or its dependencies

sounds like it would be related to [Onkyo] Building binding from github giving me unresolved requirement "org.osgi.framework" error