[OH3] Item values not shown in UI

  • Platform information:
    • Hardware: aarch64/4GB/64GB
    • OS: manjaro + linux kernel 5.10
    • Java Runtime Environment: openjdk11
    • openHAB version: 3.0
  • Issue of the topic:
    UI is not showing item values. Please have a look at the attached screenshot that shows the problem in the semantic model page. The same occurs in main pages (locations, equipments, etc.).
    However, BasicUI is working correctly. Also, the screenshot shows that values are getting recorded in persistence layer because the chart is working and showing values as they gets persisted.
    I think there must be something simple I am missing but I am lost. Logs do not help unfortunately. Nothing is wrong in logs.
  • Please post configurations (if applicable):
    • Items configuration related to the issue: Number:Temperature Living_Temperature "Temperatura [%.1f °C]" <home_thermometer_outline> (eThermostatLivingArea) ["Measurement", "Temperature"] { channel="modbus:data:al_home_plc:temperature_poller:temperature_living:number" }
    • Sitemap configuration related to the issue NA
    • Rules code related to the issue NA
    • Services configuration related to the issue NA
  • If logs where generated please post these here using code fences: none

Quick guess: Can you replace your [%.1f °C] with “[%.1f %unit%]”. Or change “Number:Temperature” into “Number”. As you already defined it is a Temperature, your pattern with “°C” is confusing the UI.


Done, but didn’t work.
Also, it happens in every item, not only the Number:Temperature ones.

Just remembered, recently, we had a similar issue

The root cause was a Antivirus program. Might be the same in your case :slight_smile:

That is really funny…
I confirm I use Sophos and that it works in other clients (tried my smartphone).

Well, I have the same issue BUT that seems NOT be the solution for me. I tested it on 2 div Windows computers, different Browsers (Edge, Internet Explorer, Chrome), different virus scanners and both Systems show the same, actually they don’t show values for certain Items in browser.
Mapping seems to be correct. Any other idea?

I found it


Thanks, I had the same issue and have searched for days to get this working. Your suggestion finally fixed my problem :slight_smile:

Thanks lot! had the same problem. thought it came from Migration from OH2.5 to OH3, did native install, same result.
Your suggestion fixed my problem as well. For others, the machine with the problem is running Avira Antivirus on Windows 10. Tested it with Windows 10 with Defender, works! Tested it with IPad, works as well.
Can anybody explain the root cause of the problem?