OH3 with InfluxDB (1.8.x) and Grafana - unable to write to database

OH: 3.1
InfluxDB: 1.8.6
Rpi: Raspberry Pi 3 B+ (B Plus) with 1.4 GHz 64-bit Quad-Core Processor, 1 GB RAM

I’ve followed the steps in the setup guide found at: InfluxDB+Grafana persistence and graphing

I’m getting a log error stating that InfluxDB cannot write to my database:


My files appear to all be the same as the influxdb/grafana as those in the set up guide (and the sine wave example from the guide does write data to my database and display in Grafana):




Strategies {
        everyHour : "0 0 * * * ?"
        everyDay  : "0 0 0 * * ?"

        // if no strategy is specified for an Item entry below, the default list will be used
       default = everyChange

Items {
	pulseOx_wellue_bloodOx : strategy = everyChange, restoreOnStartup 
	pulseOx_wellue_pulseRate : strategy = everyChange, restoreOnStartup 
	* : strategy = everyUpdate, restoreOnStartup 

I’m using a transformation for each item (both are essentially the same):

	var newStr = i;
	var compStr = newStr.substring(0,8);
	if (compStr == "FE0A5500") {
		var retVal = newStr.substring(10,12);
		retVal = parseInt(retVal,16);
		return retVal;

Here is one of my item files:

Number pulseOx_wellue_bloodOx "Wellue Blood Oxygen" {influxdb="bloodOxWellue", channel="bluetooth:generic:hci0:pulseOxWellue:service-0xFFE0-char-0xFFE4" [profile="transform:JS", function="pulseOx-wellue-bloodOx.js"]}

Has anyone run into this problem? Can anyone point me to a solution?

I have read through the following topics - sadly, have not helped me find a solution:


This thread: OH3 InfluxDB2 is about influxdb2 but it shows the same error message. May be suggestions from that thread help in your case as well.


Thank you, for sending along that link.

There is a slight difference between the error in that post (OH3 InfluxDB2) and the one I’m experiencing:
OH3 InfluxDB2 : …UnauthorizedException: unauthorized access
Error I’m experiencing : …UnauthorizedException: null

I will definitely try using a token (as per the post).

thanks again for your response.

UPDATE: unable to create a token because I’m using InfluxDB 1.8.x and not Influx DB 2.x — Still not working.