openHAB 1.8.2 available

This post was flagged by the community and is temporarily hidden.

2 Likes

Thanks @teichsta.

Is there a release note to show what’s fixed in 1.8.2 ?

yes, sure: https://github.com/openhab/openhab/wiki/Release-Notes-1.8

Perfect thanks!

I downloaded https://bintray.com/artifact/download/openhab/bin/distribution-1.8.2-designer-linux64bit.zip sevral times and tried different unzip tools, but the failed all. Maybe the package is corrupted?

I can confirm that the ZIP file is not usable, and it’s suspiciously much smaller than the files for the other platforms.

the file seem to be corrupt … i am currently uploading the binary.

Update: should be solved meanwhile.

Will you update this post once the [apt-get update / apt-get upgrade] method is available?

should be available already, isn’t it?

Ok, I should have included that as my question. I wasn’t sure of the time frame implied by “soon”. Thanks!

i’ve updated my first post …

I’m have some trouble with the upgrade. I first tried apt-get update / apt-get upgrade, resulting in:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Command:
sudo apt-get install --only-upgrade openhab-runtime
Resulted in:
E: Failed to fetch http://dl.bintray.com/openhab/apt-repo/pool/main/1.8.2/openhab-runtime-1.8.2.deb rename failed, Input/output error (/var/cache/apt/archives/partial/openhab-runtime_1.8.2_all.deb -> /var/cache/apt/archives/openhab-runtime_1.8.2_all.deb).

I’m on Raspberry Pi 2. Can anyone give me any tips on getting the upgrade to go through?

Will there be a 1.9? After my experiences with 2.0 and the snapshots - it has a long way to go…

After upgrading to 1.8.2 Setpoint item in sytemaps doesn’t seem to work properly (has no effect)

Discussion on this is here: Switch, Setpoint broken after 1.8.2 upgrade

Is there already a release plan/date for the next Bugfix Release 1.8.3?
A timeframe would be enough.

Thanks
Helmut

yes, the plan is to release 1.8.3 on the coming weekend. Assuming the three open issues can be fixed until then.

OK, then I must hurry up, found a critical Bug in KNX 1.8.2 aka the used calimero Version.
I’ll create a PR asap.

2 Likes

just updated from 1.8.1 to 1.8.2 everything works exept i don´t get Slider Items to show on Chrome browser anymore, it shows the < & > buttons, a bug or it there an workaround?

now when i go back to 1.8.1 i still don´t get any slider items i have to reinstall google chrome to get it back

i have done this to 2 laptops and my stationary computer

I have noticed that also the icon for the bulb doen’t change. You have to refresh the web page to see it updated

1 Like