openHAB 2.1 is out!


(Jens S ) #34

Unfortunately the homematic variables cannot be updated any more after upgrading to openhab 2.1! Even in the console smarthome:send varxxx REFRESH does not work any more! Only a complete stop&start of openhab service updates homematic variables once.


(chris_van_aalst) #35

Upgraded to 2.1 - (on ubuntu 14.04 lts) using:
sudo apt-get update
sudo apt-get upgrade

/etc/init.d/openhab2 status show that it is running

but accessing the webpage doesn’ t show anything (nor accessing via my App) (connection refused)
same problem with ssh openhab@localhost -p 8101 (connection refused)

I am not a Linux expert - but what am I missing - I have a Unifi NVR running on the same machine (:8443) and that one works still as it should after the upgrade ?

Can someone point me in direction where to look ?

thx

I am running Openhab1 with RFXcom, Zwave & Nikobus-bindings - and until today it was working without a glitch !


(SiHui) #36

If you are coming from openHAB version 1 you should follow the migration tutorial:

http://docs.openhab.org/tutorials/migration.html


(chris_van_aalst) #37

this is a typo - I am running Openhab2


(erland_lestander) #38

That sounds like what I experienced.
I gave up and went to sleep. - And all worked the next morning.
Do know what was wrong, what fixed it, if it will work for you.

I didn’t see any traces of OH starting in the log files , neither openhab nor events.


(Ben Clark) #39

@chris_van_aalst Try stopping openhab, clearing /var/lib/openhab2/cache and. `/var/lib/openhab2/tmp’ then starting the service.

edit: To those reading, only clear the folders, do not delete.


Many issues with v2.1
Integrate Siemens Logo (plclogo) in OpenHAB 2
(chris_van_aalst) #40

Ben,

thanks ! this fixed the problem !


(Christoph Wempe) #41

fyi:

When I delete the two folders Benjy mentioned, I hget this error in syslog.

Jun 30 22:05:02 openhab start.sh[3625]: Launching the openHAB runtime...
Jun 30 22:05:10 openhab start.sh[3625]: java.lang.RuntimeException: Exception instantiating lock class org.apache.karaf.main.lock.SimpleFileLock
Jun 30 22:05:10 openhab start.sh[3625]: Could not create file lock: Invalid karaf.lock.dir system property '/var/lib/openhab2/tmp' : does not exist
Jun 30 22:05:10 openhab start.sh[3625]: at org.apache.karaf.main.Main.createLock(Main.java:443)
Jun 30 22:05:10 openhab start.sh[3625]: at org.apache.karaf.main.Main.doMonitor(Main.java:371)
Jun 30 22:05:10 openhab start.sh[3625]: at org.apache.karaf.main.Main.access$100(Main.java:72)
Jun 30 22:05:10 openhab start.sh[3625]: at org.apache.karaf.main.Main$2.run(Main.java:362)
Jun 30 22:05:10 openhab start.sh[3625]: Caused by: java.lang.reflect.InvocationTargetException

Recreating the folder helps.
But maybe this should be handled by openhab, like it is for the cache folder.


(Angelos) #42

Yeah, I did the same some time ago…
You can safely delete cache but you shouldn’t delete tmp because Karaf needs that.
I usually clear all the stuff within the 2 dirs but don’t remove them

Good idea !


(Kai Kreuzer) #43

This should actually be the case since https://github.com/openhab/openhab-distro/pull/468.
Is the oh2_dir_layout not being executed on an APT installation…?


(Christoph Wempe) #44

I am not talking about the installation process.

After the update of 2.1 did not go well, I tried (successfully) deleting these folders, like Benjy suggested.

But starting the service did not recreate the folder.


(chris_van_aalst) #46

I have another problem: my Z-wave (AEOTEC usb-stick + 6 x ZW100 Multisensor 6 + ZG8101 Garage tilt sensor) stopped function.

I have the 2.1 Z-Wave binding - I stopped/started - unistalled/installed the binding same issue:

[me.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:ed572ecb’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): zwave.thingstate.serial_notfound

I have sym-links for my devices: ( AEOTEC Zwave stick - RFXCOM usb - USB-serial link to Nikobus)

chris@ASUS-UNIFI-NVR:/dev$ ls -l ttyA*
crw-rw-rw- 1 root dialout 166, 0 jul 1 16:59 ttyACM0
chris@ASUS-UNIFI-NVR:/dev$ ls -l ttyUSB
crw-rw-rw- 1 root dialout 188, 0 jul 1 09:38 ttyUSB0
crw-rw-rw- 1 root dialout 188, 1 jul 1 10:18 ttyUSB1
lrwxrwxrwx 1 root root 7 jun 30 21:45 ttyUSB-1000 -> ttyUSB1
lrwxrwxrwx 1 root root 7 jul 1 16:59 ttyUSB-1001 -> ttyACM0
lrwxrwxrwx 1 root root 7 jun 30 21:45 ttyUSB-1002 -> ttyUSB0

When I remove/plug in the AEOTEC stick, I correctly see the dev/ttyACM0 disappearing & reappearing .
It appears in my log see above - but I do not understand the error ,msg ?

any suggestions on what I can trry ?

thx !


(Kai Kreuzer) #47

Yes: Try creating a separate topic for it :sunglasses:


(E. Gerland) #48

Great! Thanks a lot to Kai and all the contributors!
I am really happy with OH and don’t miss a thing!
Great work!


(Pali) #49

@Kai, maybe I have missed something, but was information about the release plans some where available? If not, could that be more transparent for developers and others? I think there are many developers which are not maintainers like me and at least I didn’t know anything about the 2.1 release before it just popped out. If I have known, I would have tried to do couple of fixes and improvements before that.


(Joe Lawrence) #50

When installing make sure you don’t a have a “backup” sub-directory in your OH root. Like I did. If you do, move/rename before you start the upgrade. This was for Windows Auto update.


(Christian Häussler) #51

Synology Package are now up-to-date, too!
Try it, please:


(Michal Szymanski) #52

There is some problems with MCP23017 binding and OpenHabian 2.1, in previous version it worked properly now openhabian cannot start if this binding is installed. More information here Problem with MCP23017 under Openhab 2.1


(Mc Noisomeworth) #53

Yessssss! Images are now refreshing properly in the basicui! :heart:


(Matthew) #54

Thanks. Just before I get to installing it, do I only need to backup the /openHAB2/conf folders? Or will they automatically get synced across?