openHAB 2.5.7 release discussion

This topic can be used to discuss problems/experiences/questions on the openHAB 2.5.7 release - see details at



after the update from 2.5.6 to 2.5.7 I observed an increase of memory usage. Is someone else observing this behaviour or is it just me.
I am runnning openhab in a docker container and just upgraded the image. Configuration etc is the same but the memory increased around 25%.


is it a “normal” release? I did:
sudo apt update
sudo apt upgrade
openhabian-config option 02
after stopping openhab and rebooting system, i’m still on 2.5.6-2

Never mind. After restarting openHAB after the upgrade again, the memory usage dropped to a normal level.

Yes, it is. @Benjy, can you comment here?

I now did openhabian-config option 03. This installed also the changed add-ons…
but still on 2.5.6-2
and for the deconz binding. I can’t find the new “last seen” channel for sensors…

It seems that this new version is not available through apt.

Isn’t it allowed to send UP and DOWN commands to groups anymore? After upgrading the docker container I got this warning this morning and the rollershutter were still down:

2020-07-24 06:30:00.900 [WARN ] [lipse.smarthome.core.items.GroupItem] - Command 'UP' has been ignored for group 'gRollershutter' as it is not accepted.

Rule is:

rule "Rollladen_UP"
	Time cron "0 30 6 ? * MON-FRI *" or
	Time cron "0 30 7 ? * SAT,SUN *"
	if (gRollershutter.state > 0) {

Group definition:

Group:Rollershutter:AVG         gRollershutter	    "Rollläden"			<rollershutter>

Item definition:

Rollershutter	    rsRollershutter1Control		"Position"				<rollershutter>	(gRollershutter)	        {channel="zwave:device:controller1:node2:blinds_control"}
Rollershutter	    rsRollershutter2Control		"Position"				<rollershutter>	(gRollershutter)	        {channel="zwave:device:controller1:node3:blinds_control"}
Rollershutter	    rsRollershutter3Control		"Position"				<rollershutter>	(gRollershutter)	        {channel="zwave:device:controller1:node4:blinds_control"}

Thanks a lot!

My java ran out of heap space. I would think we have a memory leak as I didn’t change any config.

EDIT: There also was a significant change in Raspbian stable right yesterday I applied together with openhab2 packages, with the kernel major version to change. Might be related.

Is the release already available in the repos?
Tried sudo apt-get update && sudo apt-get upgrade on my ubuntu system. Latest available version is still 2.5.6-2

As I stated above: After an additional restart (after let the update settle down) I cannot confirm this behaviour anymore (as of now). I suspect it is something related to the update!?

rebooted a few times
tried opehabian-config option 2 : nothing special
option 3: it gives message "degrading 2.5.7-1 to 2.5.6-2 ???
my java path (for jython) is again reset…
after a few restarts, still on 2.5.6-2
sudo apt update (or list --upgradable) says now that there’s an update available… (to 2.5.7-1) for add-ons
gonna wait now… as it’s almost the same situation as I started.
my system seems to work now. Maybe this afternoon I’ll try again

Hi all, all fixed with the APT repository, 2.5.7 is fully available now for apt/openHABian users.

When I reverted back to my previous openHAB2 version, memory use stabilized at ~40 MB more than before so that additional space must have been caused by the kernel update.

I’ve increased the -Xmx java setting in /etc/default/openhab2 from 320m (openHABian default) to 384m and it seems to be working since, but still running the old version.

Anyone to hit the same issue, let me know here and try this fix with 2.5.7, too.

Need to reboot the system after upgrade. By only starting the service after the upgrade, there will be a lot of errors in the logs

What do you mean by kernel update? AFAIK the images did not change except openHAB itself.

That looks like a straightforward bug (as in, yes it should be allowed).
Might be best to create a Github bug report on OH core.

I think, after an upgrade you have at least to restart openhab twice.
When you upgrade the system a “clean cache” is also performed.
After the first restart you will have strange Behavior, like not existing items, “strange” entries in openhab.log and so on.
Depending on your system you should wait a long time (30-60 Minutes), if load on the system is on “normal” state, than perform a second restart of openhab.
Afterwards (hopefully) everything works as expected.

This is for me a “normal” procedure for every month update


Done. Thanks!

One of my instances of openhab2 has updated to 2.5.7, the other is still on 2.5.6-2. No idea why…

Edit: after reading @Benjy 's comment, the second install is now updating :slight_smile: