OpenHab 2 and Stiebel Eltron


does anyone have experiences with the Stiebel Eltron ISG and Openhab?

Link to the ISG (Internet Service Gateway)

There is a modbus softweare addon (sry the site is only availabe in german):

Here is the link to the tech docu of the Modbus addon.

A bit digging in the Internet let assume that one does not have to purchase the modbus part. It seems that the ISG itself can answer HTTP requests.

So does anyone run sth. like this?

There is a Stiebel Eltron Binding for OH already but i can’t get that one working:

(Those things from Tecalor are the same but differently branded)


Hi Hogan,

i would assume that the ISG may in the backround still interface to serial interface of the heatpump and the controller as described in the

If there is more interests on the binding on openhab1 for openhab2 I may restart the development and start migrating the binding.


Hi Peter,

in the end it will be a serial connection (as you mentioned)… and spending about 20€ for the cable and the USB2Serial-Adapter or 800€ for an ISG web and the modbus addon from stiebel… well not a hard choice. :wink:

For the binding: Well at leat i’m interested and if i can help you at migrating the binding, i’m in.
As i want to start binding development for OH2 anyway, that would be a good starting point. (or maybe not :wink: )


hi Hogan,

i am currently working on getting the IEC 62056 21 Meter Binding into openhab2 addons.
By that i am making first experiences with the new PaperUI features and thing/channel concept.

Have you already started on the development of the binding of stiebel for openhab?


Hi Peter,

i did not start working on the stiebel binding so far. First i have to connect my THZ 304 via serial bus.:wink:
As i work on the enocean binding atm, starting the stiebel binding is delayed for now.


Hi Hogan, started now with new binding for openhab2.
Basic configuration is working in parperUI.
Still have dificulties to get logging running in remote debigung.

Decided to implement the protocol configuration in the thing type definition.
Here the example for the version information

	<channel-group-type id="channelGroupTypeVersion" >
  <description>Version information of heat pump firmware</description>
      <channel id="version" typeId="version" >            
                <property name="dataType">Status</property>
                <property name="requestByte">0xfd</property>
                <property name="position">4</property>
                <property name="length">2</property>
                <property name="scale">0.01</property>

With the new concept if thing definition we can get ride of the xml configuration for the protocol decoding.
What is the version of firmware you have on you heat pump?


Hi Peter,

i was very busy in the last days. I hope i can find some time tomorrow to get my setup running and the heatpump-monitor working so i can get the protocol version. Saving the config in the channel-settings looks fine to me.


hi hogan,

myold openhab1 was still on version 1.7
in the meantime code has been updated in github to extend the functionality for accessing the heatpump with via ethernet.
Unfortunately the code is not working anymore for the serial port.
Will need some time to find the root cause.

will let you know in the next days


Hi Peter,

Ethernet connection was set up via ser2net?
Atm i’m trying to get the connection tested but a:

 #stty -F /dev/ttyAMA0 speed 9600 cs8 -cstopb -parenb
 #echo -ne ^02 > /dev/ttyAMA0


#la /sys/class/tty/ttyAMA0
lrwxrwxrwx 1 root root 0 Mai 18 22:08 /sys/class/tty/ttyAMA0 -> ../../devices/platform/soc/20201000.uart/tty/ttyAMA0/`

in one putty session and a

 #cat -v < /dev/ttyAMA0

in the other putty session gives me no response. My wiring should be ok… no idea what i’m doing wring here

running the gives me that:

Traceback (most recent call last):
  File "", line 274, in <module>
  File "", line 268, in main
    aP = Protocol(versionsConfigDirectory="protocolVersions/")
  File "", line 112, in __init__
    self._version = self.versionQuery()
  File "", line 249, in versionQuery
  File "", line 139, in _establishConnection
    raise IOError, "Error: heat pump does not respond - is it connected?"
IOError: Error: heat pump does not respond - is it connected?

Is there a better way to connect the heatpump to a raspi?


Well… i found out that i made a mistake in the wiring. Seems like the pin numbers Robert Penz mentioned are 3,2,1 from up to down if you look at the connector on the THZ 304. i made my connector 1,2,3 and by changing the order i destroyed the connectors… so i have to rewire that stuff. Hopefulle works after that.

hi hoga,

roberts described solution is purely RS232.
python script is the firs way to verify if connectivity is working.

hope to get things fixed at weekend and get first connection up and running again with my heatpump in openhab 2
Will tray fo focus on measurement only and not on the complete set of setting.


Hi Peter,

i’m a bit frustrated… i set up my wiring from zero just to find out that nothing really changed. Roberts script still says that the connection is not working… no clue what i’m doing wrong …

You mentioned a Ethernet connection… what exactly did you mean?


hi Hogan,

are you login with root or execute the python script with sudo ?
Do you have RS232 on Raspi and if so done all necessary step to use it a seriell interface?
If you have trouble with RS232 and the voltage level in the raspi, you may use a usb / rs232 converter in windows and use the python

I have connected my linux server in the cellar directly with RS 232. Also did some simple test with a windows PS and USB/RS232 converter.



i deactivated the GPIO serial Interface via the openhabian config tool.
I run the script via sudo in a putty session and i use a RS232/USB dongle that is connected to a usb 2.0 hub which is connected to one port of the raspi.

Will try to connect the RS232 to my windows box. Maybe i need a external powered USB 2.0 Hub?

No improvement. I connected the RS232/USb to my laptop and ran on my windows install.
The RS232/USB dongle is visible and known under COM3. gives me the same error as above.
Unfortunatley i can’t include pics of my wiring here and my multimeter to check connectivity of the cable is out of order atm.
The service guy that came once a while ago could open a connection…



the USB/RS232 will not require a USB hub power externally.

Looking at your updated info the chance is high the someting is wrong with the connection to the heatpump.


my programming skills are limited, but if it helps I would like to test the binding.
I have a LWZ 404 SOL with software-ID 5993 and software-version: 5.39.
RS232 communication with the heatpump works (tested with a teminal program at 115200 baud).

Where can I find the binding?


Hi Holger,

i think Peter is developing the binding. As it is not yet finished (i guess :wink: ) it is not yet included in the bindings of OH2.
I will contribute to the development of the bining as soon as my connection to the heatpump works.

A second beta-tester would be warmly welcome i guess :).

Btw: Peter, i have found the error of my connection problems. RX and TX were not in the right order.

I will post some further details as soon as i set up the correct wiring, so that anyone else who wants to connect a 304 eco doesn’t have to make the same mistakes. :slight_smile:


HI ,

yes basic setup of new openhab2 binding done. unfortunately the changes been done in the code by other commitments broke the communciation to my heatpump. will need to roll back some code to were i know it is working
expect to have this working next weekend
will provide a download link here in the chat


got binding working in OH2



finally i got my connection up and running.

I used the internal USB Port q /dev/ttyUSB0 with Baudrate 115200.
My Protocol version is 5.09