Openhab 3.4, Shutdown after installing Shelly Binding

Hey guys,
I have an OpenHAB instance which is working great for more than two years now using docker.

I just updated from openHab 3.3.x to 3.4.4. The system came up with some missing Bindings including the shelly binding. Leaving it as is, the system works reliably (without the features of the missing bindings ofc).

As soon as I install the shelly binding, I see messages in the console (log:tail) about the shelly things getting online and then I get the following messages after some seconds:

14:47:22.871 [INFO ] [.basic.internal.servlet.WebAppServlet] - Stopped Basic UI
14:47:24.679 [INFO ] [hab.ui.habpanel.internal.HABPanelTile] - Stopped HABPanel
14:47:25.391 [WARN ] [b.core.thing.binding.BaseThingHandler] - Handler ShellyRelayHandler tried updating the thing status although the handler was already disposed.
14:47:25.479 [WARN ] [b.core.thing.binding.BaseThingHandler] - Handler ShellyRelayHandler tried updating the thing status although the handler was already disposed.

No further exception or error. After that messages, the system goes down and is restarted by docker. Memory and disk are sufficient. Docker Console does not show any error.

Haven’t found anything similar in the forum yet.

Thanks for any help,

Hey @sihui,

you are right - I found that one :slight_smile: But following the discussion during the day, my case seems unrelated. Without the Installation of this exact binding (shelly), openhab is not restarting. The users in the referenced thread do not use the shelly binding.

I can activate other bindings which also do not cause the restart.

I also tried to clear the cache and tmp folders without effect.

I had a look on shelly binding and recent code changes. There is a larger change set, however it is included in 4.0.0.M4 and not 3.x line. There are very few differences between minor releases which would justify this crash.

Just a small addition: I posted on the other thread and I do use the Shelly binding as well. So it still might be related. I noticed in the past that the Shelly manager was unavailable from time to time (giving an error message, don’t remember what it was exactly). This might also be related?! Restarting the container brought back the Shelly manager as well.

Hey @splatch,

thanks a lot for your investigation! I just downgraded the instance again to 3.3.0 and the error is gone. As developer, I am still curious what the error may be. What are my options to get more information on the error beyond “Stopped Basic UI”. Tried to set the log level in the log:tail command to 0, but I see no affect on the messages.


The “Stopped Basic UI” is a symptom of a shutdown which been started earlier. Usually it takes several seconds to reach that stage/message. You need to look at earlier log entires.
Also instead of log:tail you can use system tail -Fcommand to follow openhab.log file. It works outside of openhab shell and might get you a bit better outcome.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.