Openhab 3 fail to install(openhabian)

Hi, i’m trying to install openhab 3 trough openhabian but it fails to install,
i’m on a raspberry pi 3b with openhab 2.5.10-1
here is the output of sudo openhabian-config:

sudo openhabian-config
2020-12-21_19:01:09_CET [openHABian] Checking for root privileges... OK
2020-12-21_19:01:10_CET [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2020-12-21_19:01:10_CET [openHABian] openHABian configuration tool version: [stable]v1.6.1-1021(01d4e59)
2020-12-21_19:01:10_CET [openHABian] Checking for changes in origin branch stable... OK
2020-12-21_19:01:13_CET [openHABian] Switching to branch stable... OK
2020-12-21_19:01:15_CET [openHABian] Updating Linux package information... OK
2020-12-21_19:01:29_CET [openHABian] Preparing openHAB installation... OK
2020-12-21_19:01:30_CET [openHABian] Beginning openHAB backup... SKIPPED
2020-12-21_19:01:44_CET [openHABian] Installing openHAB... 2020-12-21_19:01:44_CET [openHABian] Beginning install of latest openHAB3 release (stable)... OK
2020-12-21_19:01:44_CET [openHABian] Adding required keys to apt... OK
2020-12-21_19:01:46_CET [openHABian] Installing selected openHAB version... FAILED
FAILED (install openHAB)

openHAB 3 has not yet been released in the stable repo. Wait a few more days… :wink:

EDIT: Apparently it IS released…

Switch to openhab3 Branch of the openhabian tool

1 Like

I did it and got the same result :confused:

I solved it,
i needed to upgrade to the latest openhab 2.5x and then install openhab 3


@andrea_cecchi details?

oh. I just went for option nr 02 on the openhabian-config first. And then option 03