openHAB 4 Windows issue


I am having issues migrating from openHAB 3.4 to 4.0.3 on Windows 11.
These are the steps taken:

  • install latest Zulu java 17 (17.44.53).
  • reboot
  • run update script (no errors)
  • start openHAB

When opening the UI I noticed that my Zigbee Ember coordinator showed initializing and stayed like that.
Also my Milight lights, using ESP milight bridge stopped working
Other things like Shelly things and Z-wave things are working as expected.
I deleted the cache and tmp folder and restarted, but with the same result.
The openHAB log file shows quite some errors, but I don’t know how to interpret them.
I attached the log file which hopefully provides a hint what is wrong.
For the time being, I reverted to 3.4

openhab.log (15.7 KB)

Did you try restart openhab a second time.
Sometime, specially after updating, openHAB needs to be restarted/rebooted twice.

I did restart, but same issue.

Sorry, then I have no idea :frowning:

after upgrade and error did you try to refresh the binding looking at your logs it appears that the zigbee2 mqtt binding was having issues as it triggered a null pointer exception because of a field it could not access

2023-09-20 14:06:37.601 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.ExceptionInInitializerError: null

Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make field private transient java.util.NavigableMap java.util.TreeSet.m accessible: module java.base does not "opens java.util" to unnamed module @d97db2
	at java.lang.reflect.AccessibleObject.checkCanSetAccessible( ~[?:?]
	at java.lang.reflect.AccessibleObject.checkCanSetAccessible( ~[?:?]
	at java.lang.reflect.Field.checkCanSetAccessible( ~[?:?]
	at java.lang.reflect.Field.setAccessible( ~[?:?]
	at com.thoughtworks.xstream.core.util.Fields.locate( ~[?:?]
	at com.thoughtworks.xstream.converters.collections.TreeSetConverter$Reflections.<clinit>( ~[?:?]
	... 33 more

I would try to reinstall the binding and see if that helps.

Also, are you sure that the correct JAVA is being loaded and run? I had an issue with the PATH and JAVA-HOME settings on windows.

I tried this just now, unfortunately is doesn’t help.

I had a java issue when I started, but that was related to a Java bug (something with zip files)
I noticed that if my java is not configured also the upgrade script fails because of incorrect versions.
I also verified with "java --version "

Do you run openHAB as a service? Perhaps it doesn’t properly execute the startup script. Does it work if you start openHAB from the command line instead? There is some config to prevent exceptions like these by “opening” the package. By default Java class internals are unavailable but some older code still depends on Java internals so that’s why these packages are opened.

I tried starting openHAB with the start.bat from the commandline. Strange to see that now the zigbee network is working, but many other things fail instead, like my evohome. I also get an orange box on the open server with the text “communication failure”
openhab.log (18.6 KB)

Did you ever solve this issue? It happens to me, too :frowning: today I migrated from openHAB 3.4.4 to 4.0.4 and even after several restarts of openHAB’s Docker container (even after rebooting the Raspberry Pi), I see the following:

In the browser dev tools, I’m constantly seeing this request being made every couple of seconds against https://openhab/rest/events/states:

When calling log:display in the openHAB client, I don’t see any errors or warnings.

This bug has some implications as I’ve built this tool to automatically capture screenshots from an openHAB layout page - which does no longer work as the Communication failure box hides the shield icon/login button - so now I can no longer use my tool :frowning:

Oh no, it’s this issue again: Implicit user role for unauthenticated requests required · Issue #699 · openhab/openhab-webui · GitHub

After enabling the implicit user role, the error is gone - well, at least a workaround

I am still using 3.4. The upgrade to openHAB 4 on Windows doesn’t work for me. I am now trying to configure it on WSL, but it is very time consuming to get everything working. (No Linux experience).