Openhab and Envisalink Vista / Honeywell Alarm

My only guess is if you have 2FA turned on with your Ring account, the binding may not have incorporated 2FA when it was originally written.

I do NOT have 2FA turned on with my account and it works.

2022-05-02 20:11:03.324 [INFO ] [g.openhab.binding.ring.internal.RingHandlerFactory] - createHandler thingType: ring:doorbell
2022-05-02 20:11:03.369 [INFO ] [g.openhab.binding.ring.internal.RingHandlerFactory] - createHandler thingType: ring:account
2022-05-02 20:11:03.393 [INFO ] [org.openhab.binding.ring.internal.RestClient      ] - Creating Ring client for API version 11 on endPoint
2022-05-02 20:11:04.316 [INFO ] [org.openhab.binding.ring.internal.RestClient      ] - Creating Ring client for API version 11 on endPoint

Best, Jay

I tried this path as well, but I cannot deactivate 2FA.

In my profile I can only choose between adding a new number for verification or to use an authorization App.
There is no option to switch the 2FA off.

There is one option in the Ring control center to authorize new devices, but the generated code does not help with OH either:
In the thing view it still states:

2 factor enabled, enter code


Anyone have any suggestions on disarming and arming? I am able to receive status with the updated binding in this thread but I cannot successfully send commands to the alarm panel. The status just reverts to previous.

I can successfully go to the Envisalink page and send commands.

Do I need to create rules in order to change state?

Ademco Binding port from 2.5 to 3.x version - Add-ons / Bindings - openHAB Community

Thank you for your work Sriram. Any chance you have tested the binding when trying to disable the Chime on a Vista 20p?

This is the only thing I cannot get to work at the moment. Enabling chime does work.

I haven’t tried disabling chime using the bundle. Will take a look over the weekend and let you know.

Hi Basriram,

any luck in replicating the issue?