openHAB and Tasmotized ESP8266

  • Platform information: WINDOWS
    • Hardware: CPUArchitecture/RAM/storage X64/8/500
    • OS: what OS is used and which version WIN 10
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 11
  • Issue of the topic: please be detailed explaining your issue Installing Tasmotized ESP8266
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

I am trying to get confidence in openHAB. I did something in the past then I had to quit. Now I am back to it.
I installed openHAB and it is working with my devices (shellys). I was able to bind, discover and control. However I have many ESP8266 (simple version as well as MCU 8266). that have been tasmotized (I flashed Tasmota on ESP8266). I see the devices with openHAB however I can not get them controlled by openHAB. Any hint would be appreciated.

Easiest way is probably to set the home assistant option in Tasmota. Then it will be properly auto detected in openHAB.

You’ll have to give us a hint as to how you can “see the devices with openHAB” but can’t “get them controlled by openHAB”. Share your relevant configuration(s), and share what the devices are, how they work, what they expect etc.

There’s many posts on this forum specifically about integrating Tasmota flashed devices, but it’s difficult to recommend one without knowing what you’ve got.

I understand your points but I am not yet expert to explain exactly what the “picture” is.
I’ll try. As said I have two types of ESP8266 (ESP 1 - and MCU) flashed with Tasmota. They work properly, I am using them as light switches …easy and simple on/off, and they are connnected and controlled by Alexa. They are configured as Belkin WeMo devices.
I am trying now to get them controlled by openHAB.
I downloaded the binding WeMo and opeHAB actually sees the devices.
@Daniel_Linder: I am not sure what do you mean when saying: “*to set the home assistant option in Tasmota”.
I hope this helps.

Most people use MQTT when connecting to Tasmota devices, either by configuring it manually in openHAB or using the Home Assistant auto discovery as mentioned.

Your use of the WeMo binding is unusual and you may not get much support in these forums.

In the Tasmota console. Enter “SetOption19 0”. Then use the “HomeAssistant MQTT Component” in the MQTT binding.

There is no way for me to have these devices working with openHAB. Actually I am quite discouraged. First time I applied for understanding openHAB, I am back now and I still find openHAB extremely complicated. I do not understand where I am doing wrong. So far I have only shelly devices discovered and working. Samsung TV…no way…tasmota device …no way…amazon echo dot 4…stucked on “initializing”. I wonder if it is wise to invest effort and time in studying openhab and mqtt and all the rest…

Tasmota devices work perfectly in openHAB via MQTT. Did you try that, or are you sticking with WeMo?

First of all let me say that most probably my problem is my “insufficient” knowledge. I do not know for others, but I find this subject quite complex.
That said, I changed the tasmotized device settings but something is not clear - now - how to set up MQTT. Do I need MQTT “software” like mosquito?..I am pretty confused about this. If you, guys, can guide me I would appreciate.
Second issue is with echo dot 4. OpenHAB is stuck on “initializing”…what do I do wrong? :sneezing_face:

Start a new thread with this. We cannot see what you did at all, remember. Give some details there, and copy/paste complete messages. Look in your openhab.log for relevant stuff.

That si ok…could someone guide through MQTT settings…I am struggling but some confusion is drivong me mad.

You mention that you just have a ESP8266 switch. Maybe try this tutorial?

well. I went through the tutorial but I am not able to identify the broker hostname/IP to link the broker to the bridge :rage:

OK. If you have a question then let us know what you’ve tried and we might be able to help. Finding out the IP address of a device in your home network can be done many ways (see Google), but we’ll have to know what device you installed Mosquitto on in order to continue.

Well let me summarize.
OpenHAB is working with shellys devices, therefore we can assume the setup IS correct.
Follwing you can find the information from the tasmotized device.
For my understanding my local host is MY PC, so no big issue to find the IP. I know my router IP, my provider IP, all my devices IP. Nevertheless no way to get rid of the “COMM
ERROR” from openHAB

Program Version	9.5.0(tasmota)
Build Date & Time	2021-06-17T08:26:35
Core/SDK Version	2_7_4_9/2.2.2-dev(38a443e)
Uptime	0T00:00:39
Flash write Count	3980 at 0xFB000
Boot Count	100
Restart Reason	Software/System restart
Friendly Name 1	MCU2_1
Friendly Name 2	MCU2_2
AP1 SSId (RSSI)	SuperWiFi (84%, -58 dBm) 11n
Hostname	tasmota_D90C03-3075
MAC Address	A4:CF:12:D9:0C:03
IP Address (wifi)
Subnet Mask
DNS Server
MQTT Host	
MQTT Port	1883
MQTT Client	DVES_D90C03
MQTT Topic	tasmota_%06X
MQTT Group Topic 1	cmnd/tasmotas/
MQTT Full Topic	cmnd/tasmota_D90C03/
MQTT Fallback Topic	cmnd/DVES_D90C03_fb/
MQTT No Retain	Disabled
Emulation	Belkin WeMo
ESP Chip Id	14224387 (ESP8266EX)
Flash Chip Id	0x1640EF
Flash Size	4096 kB
Program Flash Size	1024 kB
Program Size	607 kB
Free Program Space	396 kB
Free Memory	26.1 kB

All we can assume from this sentence is that openHAB is running, your Shelly devices are running, and you’ve managed to integrate the two so you can control your Shelly’s from openHAB. It says nothing about anything else, much less your Tasmota devices and integration trials. Unless you’re secretly suggesting that your Shelly’s connect to openHAB via MQTT?

We’re not going to guess this snippet - please copy and paste the relevant parts of the log and share inside code fences.

Great! So for the Tasmota MQTT Host field just enter the IP address of the machine onto which you installed Mosquitto.

Oh, interesting. You actually still want to go the WeMo way? I don’t know if the two are compatible.

I think you might review how MQTT works.
Everybody involved talks to a broker, a middleman.
openHAB MQTT binding wants to connect to a broker.
The Tasmota devices want to connect to a broker.
They never talk directly to each other.
The broker is not part of openHAB.
The broker is not part of Tasmota.

It’s a separate service that is up to you to provide.
People often use Mosquitto, but it is not the only broker.
There’s no reason you shouldn’t run a broker on the same box as openHAB, if it is convenient.
It remains a separate service on that box.

If you use openhabian to manage your openHAB installation, openhabian can also manage some common add-ons like Mosquitto.

You don’t have to use MQTT at all, but it is what Tasmota was originally created for. A great many people use it this way.
If you’d rather use WeMo emulation instead, carry on and ignore MQTT, but not many other people do it this way with openHAB.


Oh, interesting. You actually still want to go the WeMo way? I don’t know if the two are compatible.

No, that was because I had to reflash the configuration and it was back to the original one.

thanks for the explanation. It helps me.

BTW After setting the local host to, the thing “MQTT broker” in openHAB is ONLINE. I am trying to understand what the next step is. Just note that if I use NO emulation in tasmotized device, Echo dot is not controlling the device. In other words it seems Alexa can control the device only if set to WeMo way (…hope I made myself clear)

To expand on

You would configure openHAB to publish (talk) on certain topics, and subscribe (listen to) other topics, by configuring MQTT Things and channels.
That’s useless until you also configure each Tasmota to listen to particular topics and talk on other topics as well.

Decide if you want Alexa to control the device directly, or if you want Alexa to do this via openHAB. This seems to control your other choices.

Ok, so far the theory is ok.
It is quite frustrating working with openHAB and all related issues. I am close to throw everything into the garbage bin. I followed the tutorial at this link:

BTW…I have:

  • openHAB MQTT broker ONLINE and bridge thing configured (step 1 tutorial);
  • tasmotized device MQTT set as required…User…topic and so on, (step 2 & 3 tutorial)
  • openHAB configure to connect to the device; (step 4 tutorial)
  • openHAB configured to control device (step 5)
  • Mosquitto in working as I checked with netstat -an and port 1883 under IP is connected/established;
    …nevertheless…the switch DOES not activate the device.
    What else can I try/check???