openHAB Cloud Connector Gateway Timeout

Since yesterday morning (Monday, March 18,2019 ~7am US EST) we began having issues with the Google Assistant integration. Typically this is due to my openHAB server being “offline”. A relatively easy bundle restart typically solves the issue. This issue is different.

I can log in to without issue and my server appears online. But when I click to access my server, it spins and spins and eventually I get a

504 Gateway Time-out
nginx/1.10.3 (Ubuntu)

The result is the same regardless of where I connect to the Internet. I tried it from home and I also tried it while traveling yesterday.

Of course, this means that no Google Assistant voice commands function because Google cannot “reach” openHAB.

I have restarted the bundle, restarted openHAB, and rebooted my server. This has not resolved the ongoing issue.

If I connect to my server locally via port 8080 on my LAN, everything functions normally through my Sitemap on BasicUI.

Please advise.


1 Like

We had this problem yesterday as well. But all is good now, (at least this part works fine for me. I can enter my server through myopenhab).
Did you try restart your openhab server?

I had restarted everything yesterday and again last night… I did that again just now and it appears to now be resolved.

It appears is still down at the moment (March 19, 2019, 10:25 PM UTC). I am still getting this error message.

# 504 Gateway Time-out
nginx/1.10.3 (Ubuntu)


I get same error, 504 gateway timeout, trying to access to dashboard.

i think this is related

Is anybody experiencing issues with new items discovery through GHome?
my situation: “hey google, sync my devices” doesn’t discover anything new, and @ my parents’ i diconnected OH and now i can’t get it it to rediscover what was previously working (no change in items files, tags, json etc)

I dont have any issue with the connection today.

It’s back!

And for me, its now down :slight_smile:

Yesterday after the reboot was good again, but today have a issue with the connection again and Alexa bridge doesnt work …

Same issue here: I can log into, it shows “online”, but I can´t access the dashboard. After a while I recive a 504 Gateway Time-out. The iOS App is not working either, when I try to connect to the remote service. In my local network everything works fine.

Same problem here…
the cloud appears online but there is no way to connect to the dashboard, and Alexa does not work either…

Restart your cloud binding.

Can you explain how to restart it?
The point is I cannot access to my openHAB’s dashboard from openhab cloud either…

In that case you can not restart it. You need to be locally at the server (or login using SSH), as you´ll need connection to Karaf. From Karaf you can restart the bundle like this:

bundle:restart [bundle-name/number]

Someone also mention to use PaperUI, entering the cloud configuration, save, and then the binding shoudl restart. But again, you still need to be local at the server then. I havn´t tried using PaperUI methode.

Thanks for the answer, and what about restarting openhab completely?
Will this restart the bundle? As I have tried already a couple of times but it did not solve the issue

restart of openhab will restart the binding as well… so thats not your issue…

Btw… At the moment, I have troubble reaching as well as the cloud connection. So dont try troubble shoot right now.

Edit - Seems like it´s on/off right now.

I have the feeling something is wrong with openhab cloud…

I have a similar issue which occurs roughly on a monthly basis, for me the problem is fixed by re-applying my UUID and Secret to the MyOpenHAB settings page. It’s quite frustrating as other people in my house can’t use Alexa or Google Home until I have time to sort it out!

(This actually happened yesterday for me so could be the same problem)

There is nothing wrong with the cloud atm. for me that is.
But I wonder if there could be geografical issues somehow. It´s strange how some people can report problems where others are running just fine… I dont know if @digitaldan have any idea of this might be a reason?