openHAB Cloud down, AGAIN


(Brent) #1

I am just wondering if the openHAB cloud is down.

Honestly, I deeply wish there was a way to take the openHAB cloud out of the chain between Alexa and my openHAB system. It is BY FAR the weakest link. Compared to everything else that is required to get voice commands to work, it goes down many times more often than anything else. :confused:


2018-12-02 21:48:19.139 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
(David Graeff) #2

I recommend the hue emulation. At least wall plugs and white bulbs work fast and reliable that way. Use the cloud for extended functionality only (thermostats, coloured bulbs).

Cheers, David


(Cyril Jaquier) #3

Seems to be down. At least I’m disconnected at the moment:

2018-12-03 02:58:37.061 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: websocket error
        at io.socket.engineio.client.Transport.onError(Transport.java:71) [229:org.openhab.io.openhabcloud:2.4.0.M6]
        at io.socket.engineio.client.transports.WebSocket.access$500(WebSocket.java:28) [229:org.openhab.io.openhabcloud:2.4.0.M6]
        at io.socket.engineio.client.transports.WebSocket$2$5.run(WebSocket.java:150) [229:org.openhab.io.openhabcloud:2.4.0.M6]
        at io.socket.thread.EventThread$2.run(EventThread.java:80) [229:org.openhab.io.openhabcloud:2.4.0.M6]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.EOFException
        at okio.RealBufferedSource.require(RealBufferedSource.java:59) ~[?:?]
        at okio.RealBufferedSource.readByte(RealBufferedSource.java:72) ~[?:?]
        at okhttp3.internal.ws.WebSocketReader.readHeader(WebSocketReader.java:115) ~[?:?]
        at okhttp3.internal.ws.WebSocketReader.processNextFrame(WebSocketReader.java:104) ~[?:?]
        at okhttp3.internal.ws.RealWebSocket.readMessage(RealWebSocket.java:97) ~[?:?]
        at okhttp3.ws.WebSocketCall.createWebSocket(WebSocketCall.java:152) ~[?:?]
        at okhttp3.ws.WebSocketCall.access$000(WebSocketCall.java:41) ~[?:?]
        at okhttp3.ws.WebSocketCall$1.onResponse(WebSocketCall.java:97) ~[?:?]
        at okhttp3.RealCall$AsyncCall.execute(RealCall.java:126) ~[?:?]
        at okhttp3.internal.NamedRunnable.run(NamedRunnable.java:32) ~[?:?]
        ... 3 more
2018-12-03 02:58:37.235 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 66162631-2b0d-48ab-871c-1616c5909e56, base URL = http://localhost:8080)

Strange error logs
(Angelos) #4

service is up and responding fast for me
http://status.openhab.org/


(Cyril Jaquier) #5

Still no remote connection here. I will try to stop/start the binding later to see if that changes anything.


(Brent) #6

Restarting the binding worked for me. Odd that the binding didn’t automatically reconnect on its own.


(Kris K) #7

Run your own instance, no issues then!


(Brent) #8

I was under the impression that Alexa would not connect to third party instances of openHAB Cloud. If it was as simple as that, I would certainly do that.


(Kris K) #9

It does. Plenty of articles on the forum about how to set it up and online. I run the openhab2 skill on my own instance just fine


(Brent) #10

Color bulbs are supposed to work in the latest test build. I have no idea how to get it to work though. I found this and have been trying to play around with it with no luck getting the devices to pair:
https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/io/org.openhab.io.hueemulation/2.4.0-SNAPSHOT/

Been bashing my head trying to figure out how to get it to work for hours now. :confused:


(David Graeff) #11

I didn’t know that you jump on the development wagon here. The hue emulation dev version is a bit broken right now and will only be fixed around this day.


(Brent) #12

I have reverted to the 2.3 version, and although very finicky to get the devices paired correctly, I have had some success. Removing already paired devices and adding them back is very difficult to do.

I have not yet been able to get every device paired, but I was at least able to pair the ones that are important to me. I am afraid to try pairing again just yet because of how finicky it is.

The devices that I was able to pair seem to work faster than before when commanding them with Alexa. So that is nice. :slight_smile: