OpenHab cloud is slow and disconnecting

Hi guys,

There is something happening with the OpenHab cloud instance from today afternoon (starting at 2022-12-29 2:52 PM UTC). It is disconnecting after every 2-3 minutes and when it is online, the communication between the cloud server and the local instance is taking 20-60sec (or simply just timing out with 504 Gateway Time-out). I’ve tried to restart the binding, reinstalled it, restarted my OH container nothing helped.
Yesterday I was updating from OH 3.3 to 3.4, so I thought it is caused by the new version, but now I’ve rolled back to 3.3 and the issue is the same. So, I strongly have a feeling, that there is something wrong with the cloud instance.
Does anyone else having the same issue? Is there anything, I can try?


See Openhab Cloud Service not reachable

Thanks for the link, I have seen one of these discussions, but I think, this issue was something else. I’m using and monitoring the cloud binding for years and have seen some temporary outages/disconnects. But yesterday it was not working at all. I was restarting/reverting everything possible, but nothing helped.

However, the issue is now resolved already, the binding is working correctly from 1:02 AM (2022-12-30). So I think, something went wrong on the server side, which is now fixed. From that time, the binding is stable.

I’ll check out the slowness, my guess is our hosting provider had a network hiccup that caused mass disconnections, and then all of those tried to reconnect which made the service very slow. This has happened many times before unfortunately.


Dan, thank you! The good news is, that it is working stable from that time.

@abal What are you using for monitoring the uptime?

Hi, since yesterday i have problems with my cloud connection. Is this related to this ?

The alexa connection not working any more.
The app can’t connect stable to my server over the openhab cloud connection.

if i try to reach the ui over the link provided in openhab cloud i get following issue in the network trace.

Same error is shwon in Debug log as well:

@peterhoeg This is my approach: