Openhab.log goes crazy

Openhab 2.1
Windows server

I have a problem with my 2.1 openhab. Everything worked fine in 2.0
The only custome thing i have is the z-wave 2.2 driver from late october.

I get 4 of this error in a second and i think it makes my rules stop working as they only work when i restart and then they stop.

My site has alot of stuff, so its not easy to start guessing.
Webcam, modbus, zwave, network health, wemo, ikea, hue, telldus.
Can anybody understand this error, what is triggering it?

2017-11-09 21:54:04.250 [WARN ] [eclipse.jetty.servlet.ServletHandler] - /proxy
org.eclipse.emf.common.util.BasicEList$BasicIndexOutOfBoundsException: index=1, size=1
at org.eclipse.emf.common.util.BasicEList.get([63:org.eclipse.emf.common:2.11.0.v20150805-0538]
at org.eclipse.smarthome.ui.internal.items.ItemUIRegistryImpl.getWidget([136:org.eclipse.smarthome.ui:0.9.0.b5]
at org.eclipse.smarthome.ui.internal.proxy.ProxyServletService.uriFromRequest([136:org.eclipse.smarthome.ui:0.9.0.b5]
at org.eclipse.smarthome.ui.internal.proxy.AsyncProxyServlet.rewriteTarget([136:org.eclipse.smarthome.ui:0.9.0.b5]
at org.eclipse.jetty.proxy.ProxyServlet.rewriteURI([77:org.eclipse.jetty.proxy:9.2.19.v20160908]
at org.eclipse.jetty.proxy.ProxyServlet.service([77:org.eclipse.jetty.proxy:9.2.19.v20160908]
at javax.servlet.http.HttpServlet.service([18:javax.servlet-api:3.1.0]
at org.eclipse.jetty.servlet.ServletHolder.handle([81:org.eclipse.jetty.servlet:9.2.19.v20160908]
at org.eclipse.jetty.servlet.ServletHandler.doHandle([81:org.eclipse.jetty.servlet:9.2.19.v20160908]
at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle([172:org.ops4j.pax.web.pax-web-jetty:4.3.0]
at org.eclipse.jetty.server.handler.ScopedHandler.handle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.session.SessionHandler.doHandle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.handler.ContextHandler.doHandle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle([172:org.ops4j.pax.web.pax-web-jetty:4.3.0]
at org.eclipse.jetty.servlet.ServletHandler.doScope([81:org.eclipse.jetty.servlet:9.2.19.v20160908]
at org.eclipse.jetty.server.session.SessionHandler.doScope([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.handler.ContextHandler.doScope([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.handler.ScopedHandler.handle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle([172:org.ops4j.pax.web.pax-web-jetty:4.3.0]
at org.eclipse.jetty.server.handler.HandlerWrapper.handle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.Server.handle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.HttpChannel.handle([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.server.HttpConnection.onFillable([80:org.eclipse.jetty.server:9.2.19.v20160908]
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob([83:org.eclipse.jetty.util:9.2.19.v20160908]
at org.eclipse.jetty.util.thread.QueuedThreadPool$[83:org.eclipse.jetty.util:9.2.19.v20160908]
at Source)[:1.8.0_131]

I’ve never seen it before but the message is just a warning. Does everything appear to work correctly? If not what doesn’t work.

If so all I can recommend at this point is to try the SNAPSHOT to see if the error goes away or live with it until the 2.2 Release happens.

OK, only thing i have prolems with is that my rules dont work.
I was thinking maybe this had something to do with it?

They work at the startup but then they stop.

Care to provide any details. Do they stop working immediately after this error shows up in the logs? Do you see any other errors? What do you mean by “dont work”? They stop triggering? They generate errors of their own? Do you see activity in your events.log when the rules don’t work?

I’m not very good in debug, so please let me know if i should have done anything different :slight_smile:

I have looked at openhab.log and event.log to start to find out why my rules dont work.
In openhab.log i see all those errors, and because they are coming up so often i dont see anthing else.
In event i see when a state is changing it will send a command, this works for one hour and then it just dont work. In event.log i see that a state is changing but i dont see the command anymore. I dont see any errors.

The rules i have is very simple like this one.
I have no errors in eclipse SmartHome and have deletet most of the rules and are only left with a few like this one.

rule “BevegelseInngang”

	Item BevegelseInngangBinary changed
	if (BevegelseInngangBinary.state == ON) {
	if (BevegelseInngangBinary.state == OFF) {


Did some more testing today.
I tried to uninstall some bindings like telldus, without luck.
I have 3 sitemap and removed the one with most stuff in it - And the errors disapeards.
I have no syntax error in Eclipse, but i have alot of frame to build a good structur.
Can it be that even tho Eclipse is not seeing an error, it can still be?

It is hard to tell what is going on. The errors already to be coming from the signal code but even that isn’t perfectly clear.

Try stopping OH, deleting the contents of /var/lib/openhab2/cache and /var/lib/openhab2/tmp and restarting OH. If there is something temporarily corrupted that should fix it.

When the error already in your logs run a top command and see if openHAB is consuming all your CPU or ram.

Tried it, without any luck. I think Openhab does not like all my frames on sitemap.
It does not seems like openhab consuming more CPU/RAM than needed, its still only stable on 20%.
I also tried to make a new .rules but did not work.

Tried paperUI new feature of rules and that works perfectly. Maybe this two problems are note related then?

Maybe i will just do it there.

Looks easy and good, the thing i see at the moment is that it could have a “Copy” when you want to make similar rules. Ofcourse this would be alot more easy with notepad++ and search/replace, but atleast it works.

I’m at a lot at this point. All I can recommend is to try running on the latest snapshot and see if you still have the problem and if so file an issue.

The intent in the Experimental Roles Engine is to allow reuse of generic rules so you shouldn’t have to copy and paste. In fact, if you want to copy and paste something that is a signal you should make your rule more generic.

I will wait for 2.2.0 stable as the rest of the household are not so happy when i have bugs in my system :slight_smile: Do you know when 2.2 is stable?

Lets say that you have a motion detector for each room, then i want to make a rule, with timeframe of with different % of dimming. After this is a good rule, i want to copy/paste it and only change trigger and output. Is there something else i should do in this case?

When the maintainers decide to release a stable.

Without seeing the specific rule I can only provide so much advice.

But I would use Design Pattern: Time Of Day to manage the times of day. I would store the dimming percentages for each light in separate Items named using Design Pattern: Associated Items to make the items. Then I’d have a single rule that triggers when the time if day changes, loops through all of your dimmers and sets the lights value based on the Item that stores the value for that time if day and light.

In fact, I don’t have dimmers but this is exactly how I control my lighting and I’ve been helping @skatun implement something similar for his heating using this approach.