openHAB Milestone builds

Updated to RC1. Still no problems. Would consider this as closed.

Is the Docker Image already out? I cant find a 2.4 RC1 Tag.

It’s waiting for approval by @cniweb in

Does stable releases will be released in the testing repo (like after RC1)?
I have switched to the testing repo because I had a few bugs in the beginning, now most of them are solved and I don’t want to mess with non-stable releases. How should I switch back?
Switch back to the stable release and do an upgrade when 2.4 is out?


Using ThingAction to get the online/offline status of a Thing seems to be broken in RC1. Or perhaps the syntax has changed?

The following line:

var status = ThingAction.getThingStatusInfo("zwave:serial_zstick:zstick").getStatus()

Was working fine until I upgraded to RC1 this morning. Now I get:

2018-12-16 14:01:40.003 [ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule 'Hourly check of critical items': The name 'ThingAction' cannot be resolved to an item or type; line 52, column 16, length 11

Would be grateful for any help anyone can give with this.



Afaik, you do not need to put ThingAction. in front - it should work without it. Could you try?


that works perfectly - thank you.

I upgraded to 2.4 M5 a while ago. Just now I try to upgrade to RC1, but I got this error:

Ign:6 testing InRelease
Get:7 testing Release [6,053 B]
Hit:7 testing Release
Ign:8 testing Release.gpg
Reading package lists... Done
W: The repository ' testing Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Does anyone know what could have caused this? It was just fine couple weeks ago.


1 Like


I don’t know the root cause, but I was getting an error just now on my Pi when I tried to upgrade.

E: The repository ' testing Release' is no longer signed.

If it helps anyone, I cleared the error by clearing the apt cache and regenerating it.

sudo apt-get clean
sudo mv /var/lib/apt/lists /tmp
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get clean
sudo apt-get update

I now get a warning, but at least I could update openHAB.

W: The repository ‘ testing Release’ is not signed.


This might be related to the fact that I had to remove some older versions (such as 2.3.0.RC1) from the apt repo to make some space for the 2.4 release. @Benjy I assume that might have broken the signature of the repo - how to bring it back? Will it automatically be properly signed again upon the next milestone publication?

The warning shouldn’t appear anymore, the repos have been re-signed.


for me the Harmony binding stopped to work after update today.
have deleted the binding and things + fresh install and discover but no success :frowning:
Status: OFFLINE - COMMUNICATION_ERROR Could not connect: Failed communicating with Harmony Hub
anyone else has the same issue ?

I have the same problem! I just wanted to create a new topic for this!

It seems that the problem is not OH (I think). Harmony Hub updated itself for me, during the evening, after that I can’t access it…

I ran into the same issue while updating the Hub to the 4.15.206 firmware.

See: Logitech Harmony Hub Binding - Communication error 4.15.206 firmware

I found exactly the same issue.
Restarted the hub, binding, OH, - no change…

That must be the case for me as well.
I just upgraded yesterday (no choice) because I needed to change my Harmony config…

What about this error (warning) which some of us is experience at start up. As far as I remeber this started with the M6 og M7 build. It´s still there in M8 and well as the new stable release.

2018-12-12 22:23:46.084 [WARN ] [e.jetty.util.thread.ThreadPoolBudget] - Low configured threads: (max=8 - required=1)=7 < warnAt=8 for QueuedThreadPool[ServletModel-18]@356cb0{STARTING,8<=0<=8,i=0,q=0}[ReservedThreadExecutor@ee83f5{s=0/1,p=0}]

It’s been there for some time before M6. You probably didn’t let the OH upgrade process change your cfg files.

I probably didn´t, cause I dont recall never be given the option!

Question is then - how to fix this?

I wonder if this could be related. I just discovered last night I have some serious problems with Grafana rendering png´s. After upgrading to M8 and now 2.4 release, it takes aprox one minute to render one picture. (with openhab 2.3 it took only a few seconds). Rendering more than one picture at the same time (same sitemap), ends with an timeout. (grafana error - “Signal: killed”).

Reading the thread I linked to would have led you to


Running Grafana is memory intensive so if you run on a SBC like a RPi you’re more likely to be out of memory.