openHAB Milestone builds


yesterday, i have upgraded from M6 to M8 and now i have the same Problems. How can i help to analyse the Problem?

Interessting update on my side. Retestet this morning and the problem is (nearly) gone.
What happend:

  • I installed the “owntracks” binding yesterday evening, had a lot of problems with 503
  • This morning no problems in the UI. So I wrote a small script, which polls the rest api frequently
  • No 503. Everything fine.
  • I uninstalled the owntracks-binding. During a short period while uninstall the binding the 503 errors reappeared for about 10 seconds
  • Afterwards no problems
  • I reinstalled the owntracks-binding. During a short period while installing the binding the 503 errors reappeared for about 10 seconds
  • Afterwards no problems so far.

Today I tried the Milestone 8 Build, but openhab always reports the following errors during startup. I used the update script to update from Milestone 7, which runs without any issue. I tried starting openHAB M8 several times.

Java runtime is “OpenJDK Runtime Environment (Zulu (build 1.8.0_181-b02)”

Is there any way to increase the number of threads?

2018-12-14 20:29:43.534 [ERROR] [org.jupnp.transport.spi.StreamClient] - Failed to instantiate HTTP client
java.lang.IllegalStateException: Insufficient configured threads: required=5 < max=5 for QueuedThreadPool[jupnp-jetty-client]@4ac409ae{STARTED,5<=5<=5,i=5,q=0}[ReservedThreadExecutor@9f29d6a{s=0/1,p=0}]
	at org.eclipse.jetty.util.thread.ThreadPoolBudget.check( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.thread.ThreadPoolBudget.leaseTo( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.thread.ThreadPoolBudget.leaseFrom( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at ~[?:?]
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.component.ContainerLifeCycle.start( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.client.AbstractConnectorHttpClientTransport.doStart( ~[?:?]
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.component.ContainerLifeCycle.start( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.eclipse.jetty.client.HttpClient.doStart( ~[?:?]
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start( ~[87:org.eclipse.jetty.util:9.4.11.v20180605]
	at org.jupnp.transport.impl.jetty.JettyStreamClientImpl.<init>( [241:org.jupnp:2.5.0]
	at org.jupnp.transport.impl.jetty.JettyTransportConfiguration.createStreamClient( [241:org.jupnp:2.5.0]
	at org.jupnp.OSGiUpnpServiceConfiguration.createStreamClient( [241:org.jupnp:2.5.0]
	at org.jupnp.transport.RouterImpl.enable( [241:org.jupnp:2.5.0]
	at org.jupnp.UpnpServiceImpl.startup( [241:org.jupnp:2.5.0]
	at org.jupnp.UpnpServiceImpl.activate( [241:org.jupnp:2.5.0]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
	at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
	at java.lang.reflect.Method.invoke( ~[?:?]
	at org.apache.felix.scr.impl.inject.methods.BaseMethod.invokeMethod( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.inject.methods.BaseMethod.access$500( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.inject.methods.BaseMethod$Resolved.invoke( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.inject.methods.BaseMethod.invoke( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.SingleComponentManager.createImplementationObject( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.SingleComponentManager.createComponent( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.SingleComponentManager.getService( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.SingleComponentManager.getServiceInternal( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.SingleComponentManager.getService( [39:org.apache.felix.scr:2.1.2]
	at org.eclipse.osgi.internal.serviceregistry.ServiceFactoryUse$ [?:?]
	at Method) ~[?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceFactoryUse.factoryGetService( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceFactoryUse.getService( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceConsumer$2.getService( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistrationImpl.getService( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.getService( [?:?]
	at org.eclipse.osgi.internal.framework.BundleContextImpl.getService( [?:?]
	at com.eclipsesource.jaxrs.publisher.internal.ResourceTracker.addingService( [20:com.eclipsesource.jaxrs.publisher:]
	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding( [?:?]
	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding( [?:?]
	at org.osgi.util.tracker.AbstractTracked.trackAdding( [?:?]
	at org.osgi.util.tracker.AbstractTracked.track( [?:?]
	at org.osgi.util.tracker.ServiceTracker$Tracked.serviceChanged( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.FilteredServiceListener.serviceChanged( [?:?]
	at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.publishServiceEventPrivileged( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.publishServiceEvent( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistrationImpl.register( [?:?]
	at org.eclipse.osgi.internal.serviceregistry.ServiceRegistry.registerService( [?:?]
	at org.eclipse.osgi.internal.framework.BundleContextImpl.registerService( [?:?]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.register( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.register( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.RegistrationManager.changeRegistration( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerService( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager.enableInternal( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.AbstractComponentManager.enable( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.manager.ConfigurableComponentHolder.enableComponents( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.BundleComponentActivator.initialEnable( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.Activator.loadComponents( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.Activator.access$200( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.Activator$ScrExtension.start( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.AbstractExtender.createExtension( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.AbstractExtender.modifiedBundle( [39:org.apache.felix.scr:2.1.2]
	at org.apache.felix.scr.impl.AbstractExtender.modifiedBundle( [39:org.apache.felix.scr:2.1.2]
	at org.osgi.util.tracker.BundleTracker$Tracked.customizerModified( [?:?]
	at org.osgi.util.tracker.BundleTracker$Tracked.customizerModified( [?:?]
	at org.osgi.util.tracker.AbstractTracked.track( [?:?]
	at org.osgi.util.tracker.BundleTracker$Tracked.bundleChanged( [?:?]
	at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous( [?:?]
	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged( [?:?]
	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent( [?:?]
	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent( [?:?]
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent( [?:?]
	at org.eclipse.osgi.container.Module.publishEvent( [?:?]
	at org.eclipse.osgi.container.Module.start( [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel( [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel( [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel( [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent( [?:?]
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent( [?:?]
	at org.eclipse.osgi.framework.eventmgr.EventManager$ [?:?]


2018-12-14 20:29:43.546 [ERROR] [org.jupnp.transport.Router          ] - Unable to initialize network router: org.jupnp.transport.spi.InitializationException: Failed to instantiate HTTP client


2018-12-14 20:29:43.547 [ERROR] [org.jupnp.transport.Router          ] - Cause: java.lang.IllegalStateException: Insufficient configured threads: required=5 < max=5 for QueuedThreadPool[jupnp-jetty-client]@4ac409ae{STARTED,5<=5<=5,i=5,q=0}[ReservedThreadExecutor@9f29d6a{s=0/1,p=0}]

Issue should be solved here

1 Like

Search function?

1 Like


I do not use the Sonos binding so I skipped this report.

1 Like

2.4.0RC1 is out.
Does that still count as a milestone ? At least I noticed it appeared in the ‘testing’ repo.

Yes, this qualifies as a milestone - the “RC” label simply shows that it is planned to be the last one before the release.

Ahm, I just updated from M8 to RC1 and hell broke loose. Feature install failed completely and some errors on Smarthome binding some error about ‘sse’ . We might want to check if this a problem for major release. Will post all the errors once I’m back home. Sonos upnp issue seems to be fixed but now new errors popping up there as well.

@marcelser Please report in this thread. I doubt that there’s an issue between M8 and RC1, it sounds more like some temporary problem, which might be resolved after a simple restart.

Here is the changelog for RC1 (in comparison to M8):

Eclipse SmartHome:

  1. Catch EOFException on creating chart images. (#6656) (detail / githubweb)
  2. Thing manager persist status of unknown things (#6604) (detail / githubweb)
  3. removed outdated json dependencies (#6661) (detail / githubweb)
  4. Fix #6662 (#6663) (detail / githubweb)
  5. MQTT: Add MQTT receive tests for all channel types (#6664) (detail / githubweb)
  6. blukii data decoding: add checks for valid data (#6665) (detail / githubweb)
  7. MQTT: thing-type xml, add channels to extensible (#6666) (detail / githubweb)
  8. added script support for MQTT actions (#6660) (detail / githubweb)
  9. Console: do not store enabled status for unkown thing (#6659) (detail / githubweb)
  10. [UoM] Added millibar unit to the Docs (#6671) (detail / githubweb)
  11. Upgraded to JUPnP 2.5.1 (#6673) (detail / githubweb)
  12. MQTT: Color channel can receive a single brightness value + HA (detail / githubweb)
  13. Connection handling improvements and volume range fixes (#6677) (detail / githubweb)

openHAB Core:

  1. New Crowdin translations (#443) (detail / githubweb)

openHAB 2 Add-ons:

  1. [plclogo] Fix compiler warnings. (fixes #4335) (#4345) (detail / githubweb)
  2. [GroheOndus] Add support for GROHE SENSE device (#3902) (detail / githubweb)
  3. [miio] add new devices (#4338) (detail / githubweb)
  4. [max] Add description of the duty cycle value (#4346) (detail / githubweb)
  5. Updated / edit some missing or otherwise distinct copyright headers (detail / githubweb)
  6. Update (#4353) (detail / githubweb)
  7. [KNX] KNX_IO_removedCheckChangedValue_enhanced_4352_from_Kai (#4357) (detail / githubweb)
  8. Deconz: Use connected flag instead of client.isRunning() (#4359) (detail / githubweb)
  9. [Konnected]- bugfix fix configuation check to properly pull the (detail / githubweb)
  10. Location accuracy threshold for distance channels (#4364) (detail / githubweb)
  11. [deconz] Remove results field from ThingDiscoveryService to fix OOM (detail / githubweb)
  12. [pulseaudio] Fix SAT findings and a few code improvements (#4363) (detail / githubweb)
  13. [KNX] Extend *-control channels v3 (#4369) (detail / githubweb)
  14. [jeelink] add reconnect interval (#4323) (detail / githubweb)

Zigbee Binding:

  1. Small refactorings of the switch-level converter (#333) (detail / githubweb)


  1. Use strict comparator for current selection widget choice (#336) (detail / githubweb)
  2. Button: apply format & transformation on state value (#337) (detail / githubweb)
  3. Button widget icon follows underlying item state (#338) (detail / githubweb)


  1. Update GitHub repo (#30) (detail / githubweb)

openHAB Distro:

  1. Delete tycho versions workdir after custom build (#826) (detail / githubweb)
  2. Updates to powershell scripts (fixes, added logic, etc) (#809) (detail / githubweb)

you’re right. after 2 restarts most problems are resolved. The remaining stuff I will check and if necessary post in testing thread.

Updated to RC1. Still no problems. Would consider this as closed.

Is the Docker Image already out? I cant find a 2.4 RC1 Tag.

It’s waiting for approval by @cniweb in

Does stable releases will be released in the testing repo (like after RC1)?
I have switched to the testing repo because I had a few bugs in the beginning, now most of them are solved and I don’t want to mess with non-stable releases. How should I switch back?
Switch back to the stable release and do an upgrade when 2.4 is out?


Using ThingAction to get the online/offline status of a Thing seems to be broken in RC1. Or perhaps the syntax has changed?

The following line:

var status = ThingAction.getThingStatusInfo("zwave:serial_zstick:zstick").getStatus()

Was working fine until I upgraded to RC1 this morning. Now I get:

2018-12-16 14:01:40.003 [ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule 'Hourly check of critical items': The name 'ThingAction' cannot be resolved to an item or type; line 52, column 16, length 11

Would be grateful for any help anyone can give with this.



Afaik, you do not need to put ThingAction. in front - it should work without it. Could you try?


that works perfectly - thank you.

I upgraded to 2.4 M5 a while ago. Just now I try to upgrade to RC1, but I got this error:

Ign:6 testing InRelease
Get:7 testing Release [6,053 B]
Hit:7 testing Release
Ign:8 testing Release.gpg
Reading package lists... Done
W: The repository ' testing Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Does anyone know what could have caused this? It was just fine couple weeks ago.


1 Like