OpenHAB Not installing Bindings or Transformations

  • Platform information:
    • Hardware: Windows/AMD Ryzen 7/16GB RAM/2TB Storage
    • OS: Windows 10
    • Java Runtime Environment:Java 1.8
    • openHAB version: 2.4 Release
  • Issue of the topic:Trying to install JSONPath
    Transformation, XSLT Transformation, or MQTT Binding results in error in openhab.log file.
019-03-02 19:33:04.542 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-mqtt': Error:
	Error downloading vn:org.apache.karaf.jaas.blueprint/org.apache.karaf.jaas.blueprint.config/4.2.1

Once it starts doing that, the error message shows up in the logs every minute as it continually tries and fails.

Any ideas?

The first thing to try is Clear the Cache

Tried clearing the cache and deleting the tmp directory. Had to re-install a copy of openHAB and Java to get it to work again. It was really weird. I don’t know if one of them was corrupted somehow but that was the only thing that fixed it.