Openhab not showing up in Homekit (home app)

Tags: #<Tag:0x00007f6175570138>
  • Platform information:

    • Hardware: Raspberry pi 3b
    • OS: Openhabian
    • openHAB version: 2.5.6-2
  • Issue of the topic: I have been trying to connect openhab to my homekit app but have been faiing constantly. openHAB doesnot even show up as a pairing option. I have been trying to contraol my Sensibo Skybox. Any idea on how to write the configuration file? I have been trying to make it work following the HomeKit Add-on posted on openhab site but no luck connecting openhab to homekit. However I can controll all the feature of sensibo skybox with openhab. Can anyone please help me with this?

Just do understand at which stage you are:

  • homekit binding installed, right?
  • new home is created in home app on iphone, right? but if you try to add new accessory you dont see openhab?
  • how you have configured your sansibo thermostat? using things/item configuration?

Yes, I already have a existing home. I am trying to pair openHab to that. This is my first time using OpenHab so is there anything else I have to do to get HomeKit to pair with OpenHab?
I have used things Items configuration. Also tried using tags and metadata but none of them work. My configuration might be wrong. But is that a reason for OpenHab to not show up in home app pairing option?

if openHAB does not appear at all in home app pairing option, then it is usually an issue with infrastructure, more precisely with mDNS routing between networks.

how openhab is connected to the network? using wire or wireless? do you have switch/firewall?
e.g. my openhab is connected to switch using wire, iphone is in wireless network and have UniFi router and i had to enable mDNS in unifi
image

another question - do you see any error or exception in log files?

Due to coverage issues in my house I have configured a central switch and have added 4 routers as access points to it. So you think mDNS might be the issue? Also maybe worth mentioning I have a other smart home devices running all the time. I also get this error when I configure Homekit Integration on openhab paper ui.

sorry about that. I am not sure how to share code

thank for sharing the log.
your config looks good.

but there is issue/bug in the version 2.6.6 of homekit binding which happens especially with fresh setup. it is fixed already but after the 2.6.6 release.

you need either downgrade to 2.6.5 or upgrade to the latest snapshot or wait for 2.6.7 release which will be probably end of July or so.

in order to upgrade to the latest snapshot you need

  • login to server with openhab (ssh or directly)
  • connect to karaf (password: habopen)

ssh -p 8101 openhab@localhost

  • find the id of the homekit binding with

list | grep Homekit

  • execute
    update <id of homekit binding> https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.io.homekit/2.5.7-SNAPSHOT/org.openhab.io.homekit-2.5.7-SNAPSHOT.jar

  • verify that binding has a new version with

list | grep Homekit

looks like this

1 Like

Thank you so much!! It finally worked :smiley:

1 Like

Hello all,

I have the some problem, but when i supply the command List | grep Homekit i dont get any answer back.

Am i doing something wrong or does this mean something else?!

What i see:
openhab_SS_command|690x391

hi Sebastian,

what you get on “list” command? do you see homekit binding on the list?