Openhab -> openhab2

I took my openhab sitemap and items file and moved them to openhab2. When in the new UI none of the thermostat values populate. I tried poking around with habmi and paper ui with no luck.

Group All
Group GF_Thermostat "Thermostat"	<thermostat> (ALL)

/* Thermostat */
Number Down_HVAC_HeatSetPoint "Heat Set [%.0f F]"   <temperature>    (GF_Thermostat) { zwave="5:command=THERMOSTAT_SETPOINT,setpoint_type=2,setpoint_scale=1" }
Number Down_HVAC_CoolSetPoint "Cool Set [%.0f F]"   <temperature>    (GF_Thermostat) { zwave="5:command=THERMOSTAT_SETPOINT,setpoint_type=1,setpoint_scale=1" }
Number Down_HVAC_Temperature  "Temperature [%.1f °F]" <temperature> (GF_Thermostat) { zwave="5:command=SENSOR_MULTILEVEL,sensor_type=1" }
Number Down_HVAC_Mode "Mode" <temperature>  (GF_Thermostat) { zwave="5:command=thermostat_mode" }
Number Down_HVAC_Fan_Mode "Fan Mode"  <temperature> (GF_Thermostat) { zwave="5:command=THERMOSTAT_FAN_MODE" }
Number Down_HVAC_Operating_State "Opp State [MAP(]" <temperature> (GF_Thermostat) { zwave="5:command=thermostat_operating_state" }
Number Down_HVAC_Fan_State "Fan State [%d]" <temperature> (GF_Thermostat) { zwave="5:command=THERMOSTAT_FAN_STATE" }`

 my sitemap:
    sitemap demo label="Demo House"
        	Frame label="Thermostat" {
        		Text label="Thermostat" {
        			Frame label="Demo" {
        				Text item=Down_HVAC_Temperature
        				Switch item=Down_HVAC_Mode mappings=[0="off", 1="heat", 2="cool"]
        				Switch item=Down_HVAC_Fan_Mode mappings=[0="off", 1="on", 2="auto"]
        				Setpoint item=Down_HVAC_HeatSetPoint minValue=60 maxValue=90 step=1
        				Setpoint item=Down_HVAC_CoolSetPoint minValue=60 maxValue=90 step=1

Everything shows up in the basic UI, but nothing populates:

This setup works fine in openhab1.

Can someone offer assistance to a noob? :slight_smile:

Are you using the Z-Wave binding from OH 1 or the one installed through Paper UI?

When I tried to create the binding through paper UI I was unable to get it to write to a default.sitemap or default.items files so I copied them over from 1.

There are two Z-Wave bindings available. The 1.x binding will work with your existing items config. You’ll need to update your item definitions to work with the 2.x binding. I would suggest going with the old binding to get everything working, and then migrating once you feel comfortable with OH 2 concepts.

In Paper UI, go to Configuration > Services > Extension Management (configure) and make sure that “Include Legacy 1.x Bindings” is enabled. Now you should see both versions in the Extensions list. Install the Z-Wave 1.x binding, and then check the zwave.cfg file generated in conf/services.

Here’s a thread with some more useful info:

Since I don’t know either 1 or 2 that well I’ll just stick to learning the new standard. I started a completely fresh project and was able to add my items successfully. Previously when I was using habmin I wasn’t seeing any sitemaps. Now I do see a “home” sitemap. I am able to control a dimmer switch successfully!

When I am looking at the thermostat I have connected all the values are null. Is this because it’s not built into OH 2 yet?

It looks like everything is configured correctly in the thing conguration:

Thank you for bearing with me.

EDIT: As soon as I submitted this the “Sensor (temperature)” value populated the remaining are still NULL.

EDIT 2: I found a “refresh” button under the thing overview. When I clicked it all the values popped up:

When I go under the Sitemap though nothing is modifiable, in either habmin or the basic UI:

Sorry for the delay in getting back to you. I see your issue. The current auto-generated sitemap is fairly limited, which I’m sure will improve as OH2 matures. Some item types (switch, dimmer, etc.) will render a widget, but number items just display as strings. I haven’t found a way in paper ui or habmin to select a widget (element) type for that sitemap.

Fortunately, you can still use OH1 style sitemap files in the conf/sitemaps directory. Your sitemap(s) from OH1 should work the same once you update the item assignments to match the items linked to your channels.