openHAB windows version 3.4.2 update is not working

The openHAB update powershell script: cd C:\openHAB
.\runtime\bin\update.ps1 Update-openHAB -OHVersion x.x.x is not working since a long time.
The cmd line version C:\openHAB2\runtime\bin\update.bat x.x.x was working so far but after the update to 3.4.2 the UI (http://localhost:8080) is not launched anymore, although the runtime is started in the karaf console.
Is there a known workaround?

Did you wait long enough to let openhab come up ?
Did you clear the cacge?
Any error in openhab.kog file?

The manual update as discribed here: Updgrade 2.4 to 2.5 on Windows 10 machine - #4 by Celaeno1 worked finaly. Is not satisfying though!

The userdate/chache didn’t exist.
I waited a long time.
The openhab.log has lots of errors, but the don’t tell me anything.

That is where the community might be able to help with.

Here is the log file:

For me also 3.4.2 update needed. To delete the cache 3 times and restarting the system few time till it run. I am using openhabian…I read a lot also on Reddit about this…so try clean cache several times and reboot the system

Problem aigain after update to 3.4.3. Openhab started but all things where undefined. I had to restore userdata folder to solve problem.

The update scripts to 3.4.4. didn’t work again. So I istalled 3.4.4 and started. The clean 3.4.4 installation worked and I closed it . After that I copied the confg and userdata folders from the 3.4.2 instalation to the new 3.4.4 one and started OH. It runs but the OH version is back to 3.4.2.
Does anyone know, how to restore a configuration (bindings, things, items, rules…) into a clean new installation?